4.0 Broke valve spring

Discussion in '2005 - 2014 Specific V6 Tech' started by The Fang, Dec 10, 2011.


  1. The Fang

    The Fang Member

    Joined:
    Sep 11, 2005
    Messages:
    617
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Tallahassee Fl
    yes just like the title says a broke spring on my #3 exhaust valve. Ford did not even get it this summer when I took it to them and they told me the injectors must be stopping up. sold me a cleaning kit too. So I shopped around and got some injectors cheaper on the net put those in and still had the problem. It would even pass a comp test, luckily I got a good mech on it.
    ;)
     
    #1
  2. echo7

    echo7 Member

    Joined:
    Mar 31, 2005
    Messages:
    550
    Likes Received:
    2
    Trophy Points:
    19
    Location:
    FL
    Bummer... o_O Hope getting it fixed doesn't turn into too much of a hassle. How many miles you up to your 05?
     
    #2
  3. The Fang

    The Fang Member

    Joined:
    Sep 11, 2005
    Messages:
    617
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Tallahassee Fl
    way to many 110k now and I drove it about 6-7k with it broke. I bought a truck to help stop racking up so many on the mustang. Boy I get great gas milage in the mustang compared to my other vehicles.
    my mech use to work at ford and hes kinda family. He luckily was able to do it without pulling it out. so it only cost me minimal. tg
     
    #3

Share This Page