302 EFI - need help w/tuning

Discussion in 'Fox 5.0 Mustang Tech' started by stangman16, May 17, 2009.

  1. Hi,

    I'm fairly new to EFI even though it's been a project for a couple years, I haven't gotten it to work correctly yet.

    1980 302 - nonHO firing order
    Holley electric fuel pump
    19# injectors
    stock upper/lower intake
    stock MAF (or it should be...)
    still got the 60amp alt, have a 3G i'll be putting in soon

    I had originally swapped the injector wires to get this project running - but it was sluggish and backfired through the intake. So, I bought a quarterhorse and Binary Editor to correct the injector firing order. Changed the injector harness and the firing order on the EEC.

    It seems like it may be running better, but everytime I give it gas it gets sluggish and then picks up on the RPM's (no tach yet...) Sometimes it still does a small backfire through the intake.

    Here's what I've got, and according to the readings I'm running rich. I have the fordfuelinjection diode kit for my EGR (since it's removed) and the car seems to idle better with the air filter removed.

    These pictures were taken at idle... which is approx 700-800 rpms, not the 13685 it shows onscreen.


    If i'm not mistaken, it's indicating my air fuel ratio is 24 ?? (could this be from the EGR eliminator kit I bought from fordfuelinjection? It was still throwing a code for the EGR)

    How can I correct the rich condition (if it's true - which I kinda believe when I give it gas and it stumbles and then accelerates)?

  2. You can't use the AFR data signal unless you have a WideBand O2 hooked up through the EGR wiring.

    You should be looking at your HEGO1 & 2 sensors...

    Your TPS is over 2v at idle... there is an issue...

    Are you getting any diagnostic codes?
    double check for vac leaks and exhaust leaks... these will make it IMPOSSIBLE to get a good tune...

  3. Okay, gotcha ty!

    From what I can tell, the HEGO sensors should be reading from 0.4 -> 0.6 ? I'll check the TPS again and see if it needs replacing. From researching most of last night, I found I'm having a problem with the EGR, even though I have that simulator installed (thought it was called a diode...anyhow) Read numerous posts indicating you still have to disabled from the ECU.

    Just like this one: 2115s.jpg

    I've found in the BE where to disable the Thermactor and EGR - I set to "Disabled" and will upload my tune when I get home in an hour or so.

    Diag codes = Yes. I wrote them down before I moved to Corpus, I just cannot find where I put them, but I remember EGR was 3-4 of them, maybe something with the TPS......I'll pull the codes again before uploading my tune.

    -----------------------found these from one of my previous posts--------------------------
    1.23.2007 Results

    (21) ECT (Engine Coolant Temp) out of range. Coolant is less than 50degF for KOEO

    (81) TAD or AM-2 (Thermactor Air Diverter)/ Secondary Air Injection Bypass (AIRB) solenoid circuit failure

    (82) TAB or AM-1 (Thermactor Air Bypass)/ Secondary Air Injection Diverter (AIRD) solenoid circuit failure

    (85) CANP (Canister Purge) solenoid circuit failure

    (84) EVR (EGR Vacuum Regulator) solenoid circuit failure

    //deleted the ones I know have been taken care of - will still pull codes after work

    DANG. I think I have an exhaust leak @ the headers to heads connection. I'll tighten them up and see if there are other leaks such as vacuum that you suggested. It slipped my mind, but I know I have an exhaust leak.. Thanks for the heads-up!
  4. codes before disabling EGR & Thermactor

    67, 81, 82, 85, 84, 95

    codes after

    15, 67, 85, 95 & 20 <--- had to scroll through the code scanners 'memory' to see this one
  5. had the 15 one before, I think that is because I'm disconnecting the battery everytime I'm done with the car for the day. ECM is refurbished due to problem solving with the Injectors firing...long story in it's own.

    67 = park/neutral circuilt fault // ?
    85 = CANP
    95 = Fuel pump monitor //due to my current wiring setup - think jrichker explained it once to me a while back

    20 - I couldn't find anything on this... and I was watching the code scanner and it never showed this number. I cleared the codes, and scrolled through the scanner memory and saw it listed after the 95

    Disconnected the TPS and it ran better at idle, then it started getting real choppy after a min. I had the idle set to ~800. Disconnected the MAF and the engine died within the next second. Guess I'll go get me a new TPS now - lol.

    I remember when we had this engine re-built it was degreed for torque, but I also remember I decided to have the internals balanced due to a shaking issue. So when I put the rotating assembly back in, and just lined-up the dots on the crank and cam according to the procedure in the manual, that does cancel out the "Degreed for torque" - correct?
  6. oh ya, here's the current log:


    I'm concerned about it saying I'm at 46 mph at a standstill, guess that could be from the TPS? Also, it's showing battery voltage at 5.25 - should I be concerned about this during my tuning process? I still don't understand why it's showing RPM 13685, unless that's not the same thing as a tachometer like I'm thinking...

    It's been a long day, but I could've sworn the TPS reading was showing the same thing after I had disconnected the TPS. I may have forgot to click "Start" again, but I'm fairly sure I did.

    Forgot to fix the exhaust leak - it'll be priority 1 tomorrow. Is this the cause for the HEGO readings so high?

    //if i post one more thread this may just be a 'blog' instead lol ;)
  7. Just realized.... you weren't actually monitoring any of the channels in either of the screen shots you posted...

    You need to hit the 'START' button in the top right of the screen for logging to begin.

    Be sure to fix the exhaust leak... trying to tune a defective hardware setup is a waste of time.

    You are making progress!
  8. wow, I feel like an idiot. I could've sworn I hit start, are you supposed to be able to hit stop afterwards? //if I hit start, then it presented me with start again, I just cannot remember, but perhaps something is not setup correctly in configuration

    Going to go check where the leak is right now, test/replace the TPS, and also disable the CANP.
  9. update:


    Didn't have gas in the tank to get it started - snapped this one while cranking.

    I took off the d/s header gasket and it does not look blown. I bought replacement gaskets and will change both sides regardless.

    Why would 1 hego give a reading and the other one be way off the chart? TPS shows it's good, and I remember I changed it last year now.
  10. Put gas in, still not starting.
    Notice how the spark value is negative? Did I burn out my coil? (less than 50 starts on it)


    Here's one with the TPS disconnected, crank - no start. Hego's are reading right, so I guess the gasket change worked. But the car doesn't start! Tried spraying starting fluid in upper intake, nothing - now I guess I have an ignition problem. My code scanner won't scan for codes, I turn the key and all I hear is the fuel pump constantly priming, and I can feel the relay click once. Perhaps the relay is bad, I thought it clicked again to stop the priming.

    Any suggestions?
  11. what computer a you running and strategy are you using. something is way off. is there a mass air conversion for the 80 computer or is it still SD.

    You need to hit stop for it to stop data logging so something is a miss. Go get some bead ferrets for the USB cable and put one near the cars computer and one near your laptop.

    I also sounds like you have a mechanical issue, send over your tune and i can look through it, but something isn't right..
  12. The 'START' button is still showing in your screen shots, which means the values displayed are questionable at best.

    If you are hitting start, and the logger quickly dumps back off, then you have another issue that you need to sort out.

    Don't get too worked up about the values you are seeing in the display... they aren't 'real'....

    Are there ferrite beads on the USB cable for the QuarterHorse?
    There was an issue on some of the USB cables that caused something similar to the datalogger shutting off.
    Might be worth contacting Craig Moates to see if your cable may be one of the affected units.