4.3 TBI Chubby nightmare

Discussion in 'Other Auto Tech' started by Darkwriter77, Dec 18, 2007.

  1. So, I nab this 2WD 2-door '89 Chevy S10 Blazer with a 4.3 V6 for $350 - dubbed it The Chubby. It ran, but barely. Needed an exhaust from the Y-pipe on back. It would start a little reluctantly, but wouldn't hold idle, and if you gave it any more than about 10% throttle, it would gag. Top speed was 30 MPH for the drive home. People in traffic behind me were not happy. :D

    Based on a prior post on here with the exact same symptom description, and because the dude claimed to have run the thing out of gas, I assumed it was a fuel pump. So, $60 down the toilet for a new pump and strainer, plus some new tank-to-hard-line fuel hoses, and a new fuel filter because the one on there looked ancient. Turns out the fuel tank wasn't even close to empty - rather, it had almost 15 gallons in there, still! So much for the running-out-of-gas and damaged fuel pump theory. So, another $9 wasted for an extra gas jug to pump out 10 gallons of fuel. :nonono:

    New pump's in, ground connection for pump and four others up front are all now clean. Pump switches on, primes, and all that good stuff. Still started up, but same symptoms as before - won't hold idle without help, gags on anything more than just a hair of throttle. I verify that it's getting spark, so that doesn't seem to be the trouble. So, I waste another $30 on a fuel pressure regulator. Bolt that turd in there. No change. Same problem. Grrrrr.

    On a whim, and because the symptoms also match those of an ignition module (as per Mr. Chilton Manuals), I took out the ignition module and took it over to Autozone for testing. It failed on 2 items out of about 7. Cool. I blast away another $40 on a new module, and plug the thing in. Now the bastard won't start AT ALL. :mad:

    Again, verified that it's getting spark. Yup, all good there. I rent some fuel injector noid lights. Yup, the injectors are getting signal to fire, but I don't see any fuel getting squirted at all into the throttle body. Fine, so that means the injectors are dead, right? I go down to the junkyard and snap up a pair of TBI injectors from a '90 S10 pickup with a 4.3 for $50, clean them gently (no chemicals used, just a toothbrush), scrubbed the filter screens off, and stuck in some nice O-rings. I crank it. It fires up for a half-second, because there was some fuel that got dribbled into the TB during the injector swap, but still no start and run. Still no fuel getting squirted, from what I can see, either. AAAAAARRRGGHHH!!! :bang:

    I'm at a total loss, here. I have spark. I have fuel pressure to the TBI. Every frickin' part of the fuel system has been replaced. I have signal to the injectors. But I have no damned fuel coming out of the TBI unit! :fuss:

    I give up. Help me? Please? Be your best friend? I'm a failure. :cry:

    Quick list of items cleaned/replaced/checked:

    Fuel pump and sock ($60)
    Fuel filter ($7)
    Fuel pressure regulator ($30)
    Fuel injectors ($50)
    Fuel hoses ($10)
    Ignition module ($40)
    Cap'n Rotor (YARRRR! $25)
    Battery (had to put one in to get it home ... $80 for the good stuff)
    5 gallons of 87 octane goodness ($15 :nonono: )
    Plug wires (FREE ... hehe. Leftovers in my garage.)
    Plugs (clean and gapped right, no weird deposits found)

    Ground connections cleaned: 1. Battery to block, 2. Battery to frame, 3. Firewall above A/C condeser, 4. Firewall near wiper motor, 5. LF frame rail.

    Main problem: No fuel squirting from injectors. Getting spark, getting fuel to TBI, getting signal to injectors, but nothing squirting into the TB.
  2. Maybe the puter is not telling them to spray?
  3. I know someone I can ask. He's a Chevy Guru. Let me know if you want me to ask him if he has any ideas...
  4. The injectors are, in fact, getting signal to spray - I verified this with the noid lights - so it's not likely to be the computer.

    I think the chances of it are astronomically distant, but maybe I replaced two bad injectors with two more bad injectors? Either that, or I have a blockage somewhere in the TBI unit's passages between the fuel pressure regulator and the injectors. Thing is, HOW would something big enough to block it get past the fuel pump sock, the fuel filter, and then the fuel pressure regulator, too?

    I had a weird thought: Maybe someone previously put sugar in the gas tank? How would I verify this? Besides tasting it, of course... :D
  5. Over time gunk can form, however I would find that strange. I'll ask my dad tonight he knows a lot about the s10's.
  6. I may wind up taking the injectors back that I bought from the 'yard today. They do have a 30-day warranty on 'em, at least. :shrug:

    Only thing is, I think that was the only set of injectors they had on hand. Poop. If that's the case, I guess I'll have to either order a set from someone on eBay (and hope I don't get screwed), or maybe find a place that can test the two injectors, themselves. That, or maybe I'll get lucky and find someone local to sell me a whole TBI unit (injectors and all) for a decent price...?
  7. Ok, I'll ask him anyway. :shrug:
  8. It seems like the injectors might be the cause, but if I remember correctly the TBI unit itself is riddled with sensors. My frame of reference here is a 1988 GMC S15, equipped with a 2.8L V6, which my dad owned about 10 years ago.

    I think it had a TPS and a fuel pressure sensor on it as well determined air/fuel flow. Is it pulling any codes?

    I read your post quick, so forgive my asking….is it an auto or manual tranny? The auto trannies had issues with the butterfly and downshift points as well.

    Let us know what you find out.
  9. Cool beans. :nice:
  10. He hasn't answered my text message yet. :(
  11. Ah. Forgot that part. Yeah, it's an auto - 700R4, I believe. I wonder, if there's something in the linkage that's not making the butterflies open, that might in turn cause the TPS not to rotate and realize that the thing's trying to get some throttle input ... uhh, right? :scratch: I dunno, I haven't had someone push the throttle to actually see if the butterflies open at all, but there feels like proper tension in the pedal and I can work the butterflies manually by hand right at the TBI, so... :shrug:

    FWIW, the TPS, IAC, and injectors are the only electronic items directly included on the TBI unit, so it's really no worse than the 5.0 ... actually a bit simpler, even more than a carb'ed 4.3 because it doesn't have the electronic choke and all that crap on there. Simpler is gooder. :D But it's also what's driving me insane, because one would think that having fewer parts to go bad would make it easier to diagnose. :(

    I can see the IAC being crappy as being a culprit behind not wanting it to hold idle, but I've never heard of a bad IAC preventing a motor from starting, at all ... but then, I'm kinda-sorta new to these TBI setups, more used to carbs and multiport injection setups, so I dunno.
  12. Well, I talked to Chuck and I'm supposed to call him tomorrow in the morning sometime. He said he'd come look at it and see if he can help figure it out. He said it's probably something stupid. Easily overlooked. I read to him from your post. :D
  13. Chuck needs to sign up. :)
  14. He won't. :lol: He's not the internet type.

    ....and when he's not sleeping or at Autozone, hes under the hood of a car. I swear, that's ALL HE DOES.
  15. Some folks at the S10 forums suggested that it might be the pickup coil. Apparently, the PIP on a 4.3 TBI controls the spark AND the fuel pump AND the injectors. Weird. While I've verified that it is getting signal to the injectors to fire while cranking, and while the fuel pump DOES prime correctly, I'm not entirely sure if it's still pumping while I'm actually cranking it - perhaps the pickup coil telling the pump to shut off, or at least not telling it to keep pumping while I crank it?

    In a rush, I bought a pickup coil for it. Haven't installed it yet. As per Mr. Chilton, I checked the pickup coil that's in there, presently, with a multimeter. With one lead on one of the pickup coil's terminals and the other touching the dizzy, I get an infinite reading - that's good. With both leads touching both terminals, I get a consistent reading right at 750, which is exactly within specs (500 to 1000), even while moving the connector around. So, now I'm unsure as to whether I should bother going ahead with replacing the pickup coil and thus risking the waste of another $17 (for a PIP and dizzy gasket) even though it tests out good, or if I should just bite the bullet and replace it, anyhow. :shrug: If I weren't getting so damned low on funds at this point, I'd replace the thing, anyhow...
  16. UPDATE: New pickup coil's in. Dizzy dropped right back into place on the first stab (yes, I marked positions before removal). Still not starting. Still not getting any fuel from the injectors. Yayyyy, another $17 down the toilet. :rolleyes:

    Going to remove the "new" injectors and clean out the TBI unit this morning, or tonight after work, and drop the old ones back in for the time being. Probably going to start hunting eBay for another set of injectors, if the TBI cleaning doesn't change anything - if I don't come up with massive chunks of gunk in there, I'm pretty sure it's not going to change things, anyhow. :nonono:
  17. Are there any salvage yards nearby to get some injectors from?
  18. Yup, that's where I got the last pair of injectors. I've already pulled those out and plopped the originals back in - which looked to be in better condition, anyhow - and I pulled off the TBI unit to clean it. Sooooo, assuming that I'd replaced two bad injectors with another two bad injectors, I'm taking those back to the junkyard tomorrow morning to see if they have another pair to exchange for 'em ... or at least gimmie a refund.

    While I had the TBI apart for the injectors, I checked the fuel passages from the lines all the way to the injector "bowls." Lo and behold, the TBI unit is clean as a whistle inside and out. Not a spec of corrosion or anything, anywhere within. So much for the clogged passages theory. :(

    The weird thing is that you can hear the fuel pump prime, but when you let off the ignition after cranking it, you can hear the pump still running for a couple of seconds, like it's priming the system again. Even if you crank it and then shut the ignition off and remove the key completely, it will prime for a couple of seconds after cranking. So, either the fuel pump is being told to shut off while it's cranking for some reason, hence the lack of fuel from the injectors, or maybe it's freaked out because everything else seems to be kosher and the ECM is thinking, "WTF, mang? Why aren't we up and running, here?" :shrug:

    Seriously, I'm running out of things to check and replace, here. Before long, I'll have an old Chubby that's mechanically 100% new ... yet it will still look like a $350 piece of crap that still won't start. :D

    Sooooo, my list of suspects now, in order:

    1. Ignition switch (shutting off the fuel pump while cranking?)
    2. ECT sensor (apparently causes the 4.3 or 2.8 TBI motors to either dump fuel or cut off completely when it fails)
    3. ECM (please, God, no! :cry: )
    4. Injectors still being crappy.
  19. YET ANOTHER UPDATE: Ignition switch is good. Coolant temp sensor tests good. Replaced the ignition module again (free under warranty) and tested that one before putting it in. Swapped the junkyard injectors for another pair that are known for certain to be good (they look practically new and test good for continuity). Every frickin' ground I can find on the car has been removed, cleaned, and reinstalled.

    STILL NO START. :cry:

    The ONLY thing left is the ECM. Dammit. If I replace this bastard and it doesn't fix it, I'm just going to push this sucker out in the street and torch it. :fuss: