Looking forward to Stangnet knowledge "Collective"

ragsrule

New Member
Feb 18, 2020
1
0
1
73
Punta Gorda
I've inherited a 1999 4.6L GT. :D
228K miles
No dents or dings...EVER, or even a hint of rust, though it has sun-damaged paint sitting outside in Florida.
Presently, she has an issue with P1151 which indicates a Lack of HO2S-21 switch.:oops:
So my question, "Where the Ding-Dong" is this puppy located?

Also, the odometer is on intermittently which I thought I had remedied when I took out the dash and cleaned all the connections. It was good for a day, but does come on more frequently now. Could the issue be the one ribbon cable from the back of the dash unit to the circuit board?

I know...rude to just jump in with both feet.
Thanks for allowing clowns in.
 

Attachments

  • Sponsors(?)


08GT500

Active Member
Jul 12, 2018
858
133
53
49
Massachusetts
Hi,
That’s a Ford specific code regarding the Drivers side heated 02 sensor upstream of the Catalytic converter(closest to the motor).. Car still runs good, no idle issues or hesitation under a heavy foot or load?
Jump in with both feet and have at it, lol!
Have a decent Scantool? Plug it in after resetting the code & watch for an 02 sensor “pegging”(not correcting, enter “PID’s” and watch real-time data, if an 02 sensor stays at one reading & doesn't move).
Removing the 02 sensor out of the passenger side & swapping it over to the the drivers side, if the code migrates to the passenger side, it’s likely the sensor. An exhaust leak from the exhaust manifold to the motor may also cause this, or any exhaust manifold leaks on the drivers side.
An overfilled oil level may cause this issue, I’d stick to the most common, then move on to others using the process of elimination.
The sensor may also be cleaned where it inserts to the exhaust system.
1) An 02 wire going to the sensor sitting on the exhaust may be melt the wire(s), follow the wires up from the sensor and see what you find, check any inline connections for corrosion or moisture. Clean, add a little dielectric grease to each connector pin, once cleaned, see if that remedies it.
2) Look for any old vacuum lines causing a leak & if any are hardened, or brittle, cracked, or there’s a bad vacuum. I suggest adding a fuel pressure gauge directly to the fuel
rail, comes in handy when troubleshooting.
4) Check the HEGO ground, used for the 02 sensors and verify connection(s) as solid, repair as necessary.
- Don’t test the 02 sensors with a multimeter across the sensor, it’s too delicate to handle the voltage the meter uses and will likely destroy it.
-I’m uncertain about the the Odometer and the H02 issues being directly related but I have no idea what may have been disturbed think it a good idea to follow up on that and the wires to see if there’s an issue that indirectly connects the two, follow the 02 sensor wiring carefully and check to see if the ground or signal wires been disturbed, if the culprit hasn’t yet been located, it’d be a good idea to follow up on that.
If you have any questions, please don’t hesitate to ask.
Good luck!
-John
 

aprilfleming

New Member
Mar 17, 2020
1
0
1
37
Traverse City, MI
ggstreetview.com
Hi,
That’s a Ford specific code regarding the Drivers side heated 02 sensor upstream of the Catalytic converter(closest to the motor).. Car still runs good, no idle issues or hesitation under a heavy foot or load?
Jump in with both feet and have at it, lol!
Have a decent Scantool? Plug it in after resetting the code & watch for an 02 sensor “pegging”(not correcting, enter “PID’s” and watch real-time data, if an 02 sensor stays at one reading & doesn't move).
Removing the 02 sensor out of the passenger side & swapping it over to the the drivers side, if the code migrates to the passenger side, it’s likely the sensor. An exhaust leak from the exhaust manifold to the motor may also cause this, or any exhaust manifold leaks on the drivers side.
An overfilled oil level may cause this issue, I’d stick to the most common, then move on to others using the process of elimination.
The sensor may also be cleaned where it inserts to the exhaust system.
1) An 02 wire going to the sensor sitting on the exhaust may be melt the wire(s), follow the wires up from the sensor and see what you find, check any inline connections for corrosion or moisture. Clean, add a little dielectric grease to each connector pin, once cleaned, see if that remedies it.
2) Look for any old vacuum lines causing a leak & if any are hardened, or brittle, cracked, or there’s a bad vacuum. I suggest adding a fuel pressure gauge directly to the fuel
rail, comes in handy when troubleshooting.
4) Check the HEGO ground, used for the 02 sensors and verify connection(s) as solid, repair as necessary.
- Don’t test the 02 sensors with a multimeter across the sensor, it’s too delicate to handle the voltage the meter uses and will likely destroy it.
-I’m uncertain about the the Odometer and the H02 issues being directly related but I have no idea what may have been disturbed think it a good idea to follow up on that and the wires to see if there’s an issue that indirectly connects the two, follow the 02 sensor wiring carefully and check to see if the ground or signal wires been disturbed, if the culprit hasn’t yet been located, it’d be a good idea to follow up on that.
If you have any questions, please don’t hesitate to ask.
Good luck!
-John
Ok, that is clear now. Thank you for your answer.
 
Thread starter Similar threads Forum Replies Date
J New to the forum and looking forward to some expert help The Welcome Wagon 1
Jake8 Looking forward to meeting other mustang enthusiasts The Welcome Wagon 0
ProKiller movie most looking forward to 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 20
EXTRPR50 I look forward to joining the club.. SVT Tech Forum 5
gruvee87vertgt Anyone here looking forward to watching "Fast and Furious Tokyo Drift"? 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 76
G Looking forward to the Vert... 2005 - 2014 S-197 Mustang -General/Talk- 22
74stang2togo Look what's on Ebay... 1974 - 1978 Mustang II Talk & Tech 3
89SportVert Looking for MVMA for 1974, 1975 and 1976. 1974 - 1978 Mustang II Talk & Tech 4
L Looking at a 2013 GT need opinions. 2005 - 2014 S-197 Mustang -General/Talk- 1
B Looking for a support part # for a '99 GT 35th anniversary spoiler 1996 - 2004 SN95 Mustang -General/Talk- 0
J WTB/Trade Looking for ‘87 GT 5.0 5sp 2D Fox Body Mustangs For Sale (1979-93) 1
9 AOD to T56 swap - looking for a good shop to do it...any recommendations? 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 9
P Hello all - V6 Vert 5 speed standard Owner - looking for guidance, input, advise + help SN95 V6 Mustang Tech 1
B WTB/Trade Looking For a Nice 200 ci Inline 6 Engine and Power Adder 1
9 Suspension Tires rubbing. Looking for spring recommendation Fox 5.0 Mustang Tech 14
rayray33 Looking to add Long Tube Headers for my 2019 GT 2015+ (S550) Mustang -General/Talk 2
H Adding Factory Look Air Conditioning to 70 Without It 1965 - 1973 Classic Mustangs -General/Talk- 1
J Looking for 2005 GT OBD2 idle sensor reading 2005 - 2014 S-197 Mustang -General/Talk- 2
4 Who was looking for 200 ci motor mounts ? 1965 - 1973 Classic Mustangs -General/Talk- 0
4 Who was looking for 200 6cyl motor mounts ? 1965 - 1973 Classic Mustangs -General/Talk- 0
S Electrical 1995 Mustang GT slight hiccups/hesitation at around 2k rpm looking for a fix for the dreaded code 212 1994 - 1995 Specific Tech 2
S WTB/Trade Looking for a 1999-2004 axle housing Drivetrain Parts 0
M Looking for clips to attach the rocker panel moldings and trim on a 1970 Mach I - any help is apprciated Classic Mustang Specific Tech 2
K How does this look in terms of a list of mods for my '04 3.9L v6 SN95 V6 Mustang Tech 9
nickyb Fox Looking at going back to a stock air box? 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 32
6 Looking for friendly san antonio inspection! Regional Forums and Event Information 1
T Decent deal on these cars? Or keep looking? 2010 - 2014 Specific Tech 4
A Fox Looking to buy fox top 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 5
D New Member Looking .. The Welcome Wagon 2
R New member looking for louvres 1974 - 1978 Mustang II Talk & Tech 11
R New member 2000 Mustang,looking for guidance. The Welcome Wagon 3
860 Fox Forced Induction 351W fox going to On3 kit looking for suggestions Fox 5.0 Mustang Tech 6
J Idle issue still!! Replaced several parts.. looking for more ideas!! Fox 5.0 Mustang Tech 12
P Looking to get a Intake plate 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 0
F looking for a little insight on a 302 swap for a 99 stang 1996 - 2004 SN95 Mustang -General/Talk- 6
L Just bought 2010 GT with 38k, what should I look out for? 2010 - 2014 Specific Tech 4
65Stang86 WTB/Trade Looking for used edelbrock 7121 performer rpm intake manifold Engine and Power Adder 0
S New Guy 2003 GT looking for intake manifold upgrade recommendations SN95 4.6L Mustang Tech 1
T Looking for 5-0 carb swap help in exchange for documented tech. The Welcome Wagon 1
C Looking for some suspension advice. SN95 4.6L Mustang Tech 0
M WTB/Trade Looking for 2000-2004 Salvage GT SN95 Mustangs For Sale (1994-04) 0
derek2079 Looking for these 67/68 side scoops. Pic included. 1965 - 1973 Classic Mustangs -General/Talk- 1
DarkFox Electrical I've searched for wiring diagrams but did not find what I was looking for. Fox 5.0 Mustang Tech 4
S Old Foxbody owner looking to own again. The Welcome Wagon 4
W Newbie looking to identify or confirm a 93 Cobra Engine? 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 37
T Looking for 1976 parts suppliers 1974 - 1978 Mustang II Talk & Tech 5
L Looking for a Fox: All Advice Welcomed 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 13
79pace Moates / TwEECer / MicroSquirt? Which one should I look into? Digital Self-tuning Forum 16
W Drivetrain Hello from a new Fox Body owner in Florida! Looking for advice on Immediate things to address re: steering, radiator, seat Fox 5.0 Mustang Tech 24
A new here looking for quality of life upgrades for my 1971 Mustang 1965 - 1973 Classic Mustangs -General/Talk- 2
Similar threads