problems with idle and transmission shifting

Danny95GT/GTS

New Member
Jun 16, 2019
3
0
1
70
Winter Haven, FL
90 percent of the time the car works perfectly. Sometimes when I start it up it won't idle If I raise rpms it will run and after a few minutes the rpms go up and I can let off the gas and it idles like it's supposed to. It will then shift correctly and drive normal. sometimes this will last all day and sometimes after 20 or 30 minutes it will show amps drop low and transmission torque converter will lock up and shifting will be hard and drawn out from normal. I've changed the idle control valve and the tps but that didn't help. It has a 70mm throttle body on it and bbk headers and pypes loud mouth exhaust from headers back. when she wants to play right runs and drives like a dream
 
  • Sponsors(?)


Hudson N

Member
Aug 7, 2018
45
1
8
Queen creek Arizona
90 percent of the time the car works perfectly. Sometimes when I start it up it won't idle If I raise rpms it will run and after a few minutes the rpms go up and I can let off the gas and it idles like it's supposed to. It will then shift correctly and drive normal. sometimes this will last all day and sometimes after 20 or 30 minutes it will show amps drop low and transmission torque converter will lock up and shifting will be hard and drawn out from normal. I've changed the idle control valve and the tps but that didn't help. It has a 70mm throttle body on it and bbk headers and pypes loud mouth exhaust from headers back. when she wants to play right runs and drives like a dream
That sounds electrical or PCM related. I'd start with checking all your wiring.
 

General karthief

wonder how much it would cost to ship you a pair
Mod Dude
Aug 25, 2016
14,121
4,447
193
polk county florida
This problem was addressed in another post you made.
you may in fact have to separate problems.
as suggested in the other thread you need to check for codes first.
I believe the trans on the 94-5 are still controlled by a tvs cable, check the cable connection at the throttle body, I think the clip is plastic and may have broken.