Fuel The fuel pump doesn't stop priming and I can hear a hissing noise on the lower intake area (passenger side).

Trilldev123

Member
Dec 25, 2021
36
6
18
I just installed a painless 60510 engine harness in my fully-stock 88 GT. When I turn the key for the fuel pump to prime, it doesn't stop after the usual 3-5 seconds. The pump stays on and there's a constant hissing noise from the lower intake passenger side fuel rail. I removed the upper intake thinking that It was a stuck open injector on cylinder 1 or 2, but I stuck a rod with a towel on the end down each lower intake port (all 8) to check for gas while it's priming and no wet gas spots from any of the injectors from inside the intake port. I was having issues figuring out how to wire everything with the inertia switch and kept using the old fuel pump relay circuit in the factory spot while having a new fuel pump relay provision included in the new harness. I finally got the pump to prime because I connected the red/black wire that comes from the inertia switch to the green 8 pin plug by the ECU to the injector power source wire. It now primes and I get fuel to the fuel rail because I pushed the pressure release and fuel came out. But again the pump doesn't turn off and I have that hissing noise until I shut the key back off.

Can using both the new and old fuel pump relays cause the pump to stay on? Does the fuel pump stop after the ECU sees optimal psi? since the injectors haven't sent any fuel into the engine, a stuck open injector couldn't be the culprit. I'm thinking that if the ECU needs optimal psi to tell the fuel pump to turn off. Could the hissing noise be an air leak causing the fuel system not to build up enough pressure, therefore, keeping the pump on? I also see 30psi of fuel pressure at the Schrader valve so I'm stumped.

I would send a video of the hissing noise from my phone but It doesn't allow or I just didn't figure out how. All replies are appreciated.

Thanks.
 
  • Sponsors (?)


vristang

15 Year Member
Mar 31, 2005
4,933
106
124
Not sure on the hissing….
How long does pressure hold after the pump is shut off? Maybe regulator?

The ecu doesn’t have a fuel psi input, so the pump primes on a timer.
If it isn’t turning off, then something is likely wonky in the fuel pump relay… and it sounds like you already had some difficulty there?

I’d start at the fuel pump relay.
Cut one of the relays out. The redundancy won’t improve anything.
Confirm the ecu sends the prime trigger, and shuts off, with a voltmeter, at the ecu.
Then move out to the relay and start confirming voltages there…
 
  • Like
Reactions: 1 user

Trilldev123

Member
Dec 25, 2021
36
6
18
Not sure on the hissing….
How long does pressure hold after the pump is shut off? Maybe regulator?

The ecu doesn’t have a fuel psi input, so the pump primes on a timer.
If it isn’t turning off, then something is likely wonky in the fuel pump relay… and it sounds like you already had some difficulty there?

I’d start at the fuel pump relay.
Cut one of the relays out. The redundancy won’t improve anything.
Confirm the ecu sends the prime trigger, and shuts off, with a voltmeter, at the ecu.
Then move out to the relay and start confirming voltages there…
THANK YOU for the straight answer. Most people in other forums changed the subject and wasted my time criticizing me and what I didn't need to do leaving me with no direction.

I haven't waited to see if the pressure drops actually, I will most definitely look into that and take away one of the relays and will come back if I figure it out.

Thanks again.
 

Mustang5L5

Put lubricant all over the balls
Mod Dude
Feb 18, 2001
39,490
15,333
224
That sounds to me like fuel spraying directly into the intake manifold via a stick open injector. It has that distinct “echo” of sounding like it’s down a runner.

You might have one of the injector wires grounded causing the injector to stay open. Unplug all 8 injectors and I bet that goes away

If that’s the case, I think you need to recheck your wiring.
 
  • Useful
Reactions: 1 user

Trilldev123

Member
Dec 25, 2021
36
6
18
That sounds to me like fuel spraying directly into the intake manifold via a stick open injector. It has that distinct “echo” of sounding like it’s down a runner.

You might have one of the injector wires grounded causing the injector to stay open. Unplug all 8 injectors and I bet that goes away

If that’s the case, I think you need to recheck your wiring.
Unfortunately in the video, all 8 were unplugged lol. My dad and I were trying to unplug each but nothing changed. Also, after all were unplugged, we stuck a dry towel down each intake port to at least the injector tip while the pump was priming, and no fuel on the towel :(
 

Mustang5L5

Put lubricant all over the balls
Mod Dude
Feb 18, 2001
39,490
15,333
224
That’s strange. And it only does this when you pressurize the fuel system by running the pump?

Since you have it apart, I would probably remove the 4 screws holding the rail to the lower and wiggle it up to expose all the injectors and try it.

I know you said you stuck a towel down there, but that does sound like fuel spraying.

Of course, I’d imagine if it was you’d smell it by now. :shrug:
 
  • Useful
Reactions: 1 user

Trilldev123

Member
Dec 25, 2021
36
6
18
That’s strange. And it only does this when you pressurize the fuel system by running the pump?

Since you have it apart, I would probably remove the 4 screws holding the rail to the lower and wiggle it up to expose all the injectors and try it.

I know you said you stuck a towel down there, but that does sound like fuel spraying.

Of course, I’d imagine if it was you’d smell it by now. :shrug:
Yes, it is very strange and it does only happen when the system is priming. I eventually smelt a little fuel, but not instant and nothing as if gas was being sprayed near the opening of the intake port and fumes were coming out. I'll definitely try to expose the injector tips with the rail connected and see what happens. These injectors were changed to bosch ev1 19lb injectors 2 years ago and I barely drove the car mayyybee 100 miles and couldn't see the o rings being bad? I oiled them before installing to prevent rips. But the car has sat for most of my 2 year ownership.
 

7991LXnSHO

wanna catch the space herp
10 Year Member
Sep 1, 2010
7,388
3,091
194
Unfortunately in the video, all 8 were unplugged lol. My dad and I were trying to unplug each but nothing changed. Also, after all were unplugged, we stuck a dry towel down each intake port to at least the injector tip while the pump was priming, and no fuel on the towel :(
Brainstorm time. Could it be the Fuel Pressure Regulator? If the FPR diaphragm goes, it usually leaks into the vac line. But is there another way for it to leak pressure? @Mustang5L5
A hose, long screwdriver or stethoscope could help trace the noise down if your sniffer cannot.
 

Mustang5L5

Put lubricant all over the balls
Mod Dude
Feb 18, 2001
39,490
15,333
224
Pass side is where the FPR is. It could be spraying jb there past the diaphragm

This is one of those situations where I wish the car was in front of me.

A good technique ive used to pinpoint sounds is to take a piece of 1/4” vac line, stick one end in my ear, and move the other end around listening for the sound. When you find it, it gets very loud. You can stick the end down in each cylinder and if that’s the cause it will be quite obvious.

You can also pull the vac line off the FpR and hold the tube next to the vac port. That might give you a result.
 

Trilldev123

Member
Dec 25, 2021
36
6
18
Brainstorm time. Could it be the Fuel Pressure Regulator? If the FPR diaphragm goes, it usually leaks into the vac line. But is there another way for it to leak pressure? @Mustang5L5
A hose, long screwdriver or stethoscope could help trace the noise down if your sniffer cannot.
The upper and lower intake was just put back on due to an oil leak behind the lower intake and I removed the fuel rail from the car, separated the regulator from the rail as well as each injector and cleaned the mating points (o-rings) but didn't do an injector cleaning. I used the typical carb cleaner for the regulator and hopefully didn't mess up the diaphragm. I didn't mess with the psi screw and installed it back on how it was before. When I wiggle the fuel rail near the alternator where it drops down on the side of the engine the noise changes with my movements. I checked fuel psi at the Schrader valve and it climbed to 30 psi but took a minute to start registering psi on the gauge. I never checked to see if after stopping the priming if the psi held the pressure.

If anyone needs more videos or photos for reference let me know
 

Trilldev123

Member
Dec 25, 2021
36
6
18
Pass side is where the FPR is. It could be spraying jb there past the diaphragm

This is one of those situations where I wish the car was in front of me.

A good technique ive used to pinpoint sounds is to take a piece of 1/4” vac line, stick one end in my ear, and move the other end around listening for the sound. When you find it, it gets very loud. You can stick the end down in each cylinder and if that’s the cause it will be quite obvious.

You can also pull the vac line off the FpR and hold the tube next to the vac port. That might give you a result.
The information given by you guys is great. I always love hearing different ways people try things that work for them. I'll definitely try these techniques today and let you know where I pinpoint the noise.
 

7991LXnSHO

wanna catch the space herp
10 Year Member
Sep 1, 2010
7,388
3,091
194
Pass side is where the FPR is. It could be spraying jb there past the diaphragm

This is one of those situations where I wish the car was in front of me.

A good technique ive used to pinpoint sounds is to take a piece of 1/4” vac line, stick one end in my ear, and move the other end around listening for the sound. When you find it, it gets very loud. You can stick the end down in each cylinder and if that’s the cause it will be quite obvious.

You can also pull the vac line off the FpR and hold the tube next to the vac port. That might give you a result.
I see the FPR in the pic. Seeing the car in person would really help. That’s quite a noise in the video.
 

vristang

15 Year Member
Mar 31, 2005
4,933
106
124
If it only happens when the pump is running, and the injectors aren’t leaking, then about all that is left is the regulator.
As said above, typical failure will blow fuel into the vac line, have you checked the fpr vac line for fuel?….
Could also fail in full bypass though, without leaking into the vac line? I’ve never seen that, but who knows…
 

Mustang5L5

Put lubricant all over the balls
Mod Dude
Feb 18, 2001
39,490
15,333
224
Yes, during normal operation the pump runs all the time at one speed. They fuel travels to the rail and meets resistance at the fuel pressure regulator. The rail (and injectors) are kept pressurized at 30-39psi (depending on vac load) and all excess fuel is returned to the tank

During priming, the pump runs for 1-2 seconds and then switches off if there is no tach signal indicating a running engine
 
  • Useful
Reactions: 1 user