New 04 Cobra...clunk when I engage 1st gear

Discussion in 'SVT Tech Forum' started by OregonMustang, Aug 28, 2004.


  1. Rogue Cobra

    Rogue Cobra New Member

    Joined:
    Dec 27, 2003
    Messages:
    295
    Likes Received:
    0
    Trophy Points:
    0
    Well, I just got my Cobra back from being fixed. WOW, what a difference. They did this TSB and replaced the Clutch also. It is like a different animal now. The clutch is lighter and easier on the leg now. The shifting is smoother and no chadder anymore. Now the clutch release spot is at the top of the pedal and not at the bottom like it used to be. This is going to take a little getting used to.
    #21
  2. alfman9

    alfman9 New Member

    Joined:
    Apr 9, 2004
    Messages:
    219
    Likes Received:
    0
    Trophy Points:
    0
    I just dropped mine off at the dealer. I showed him th tsb you guys gave me and he stapled it to the write-up. Guess we will see what happens. They are also suppose to fix the drivers door from the window hitting the roof.
    #22
  3. DroptopSVT

    DroptopSVT New Member

    Joined:
    Apr 16, 2004
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    0
    Picked up the Cobra today after two friggin' weeks driving one of their sad excuses for a loaner (focus). They replaced the trans part and didn't make any difference whatsoever. I pulled into my driveway, and I still have the grinding sound. I'm through taking this car into the dealer-

    Bunch of high school dropouts working at Ford-
    #23
  4. punkgt

    punkgt New Member

    Joined:
    Nov 30, 2003
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    As a high school drop out, I take great offense to being compared to a Ford Dealer Tech. You crossed the line buddy :)
    #24
  5. Rogue Cobra

    Rogue Cobra New Member

    Joined:
    Dec 27, 2003
    Messages:
    295
    Likes Received:
    0
    Trophy Points:
    0
    :lol: :rlaugh: :D
    #25
  6. alfman9

    alfman9 New Member

    Joined:
    Apr 9, 2004
    Messages:
    219
    Likes Received:
    0
    Trophy Points:
    0
    Sounds like I got stuck with the same crappy focus. Got my car back, they fixed the window no problem. BUT, they said that they didn't hear or see anything that wasn't normal operating sounds. They also stated that with a build date of 3-10-04, my car already has the part on the TSB. What do you guys think?
    #26
  7. DroptopSVT

    DroptopSVT New Member

    Joined:
    Apr 16, 2004
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    0
    Once again, looks like the dealer techs at Ford have no clue what they're doing....
    :notnice:
    #27

Share This Page