New SCT X3 91 and 93 octane tune

Discussion in '2007 - 2014 Shelby GT500 Tech' started by meterman, Aug 17, 2009.

  1. meterman

    meterman New Member

    Joined:
    Aug 17, 2009
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    I am new to programming the computer on cars, although I've worked on computers for 10 years. I just bought a 2007 Shelby GT500 Cobra, which is stock. Since the car is set up for 91 octane and it's not available at many gas stations I bought a SCT X3 from a dealer and he made a custom tune for me for both 91 octane and 93 octane.

    Today I picked up the X3 and installed the 91 octane tune and immediately noticed that the car idles around 1500 rpm when I stop and doesn't slow down to 850 rpm for about 6-10 seconds.

    While driving if I let my foot off the gas it feels like I have the cruise control on because the idle is still at 1500 rpm.

    When downshifting I don't get the same engine braking effect either.

    Is this NORMAL and how it should be?

    thanks so much in advance,

    meterman
     
    #1
  2. mjk

    mjk Member

    Joined:
    Jun 22, 2006
    Messages:
    106
    Likes Received:
    0
    Trophy Points:
    17
    Location:
    NE IL
    doesnt sounds normal to me, especially since it didnt do it before... I would consider contacting one of the more reputable tuners on the net and if theyre close to you getting a custom dyno eval...
     
    #2
  3. meterman

    meterman New Member

    Joined:
    Aug 17, 2009
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Thanks, acutally after letting the car sit for a few hours everything seems fine. Not sure if it's because I didn't shut the car off after installing the tune. Now the car runs GREAT. the boost kicks in as soon as I punch it, where it had a few second lag.
     
    #3

Share This Page