No Horn, No Foglights, No Brights

Discussion in '2005 - 2009 Specific Tech' started by seabas2020, Jan 15, 2013.

  1. seabas2020

    seabas2020 New Member

    Joined:
    Apr 27, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    I have a 2006 mustang gt. I don't have a horn, foglights, or brights. I have checked the fuses and swapped relays and that didn't change anything. I have tried both pushing the horn, and using the panic button, and it doesn't respond to either. Any ideas?
     
    #1
  2. seabas2020

    seabas2020 New Member

    Joined:
    Apr 27, 2004
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    I thought it could be the Multi function switch, but when i activate the hi beams, the indicator light on the instrument cluster comes on, so I don't think that is it.
     
    #2
  3. thd245

    thd245 Member

    Joined:
    Nov 11, 2012
    Messages:
    48
    Likes Received:
    1
    Trophy Points:
    9
    Sounds like wires or fuses. You said you replaced the fuses and relays, but that is what it sounds like.
     
    #3
  4. tr7driver

    tr7driver Member

    Joined:
    Sep 5, 2006
    Messages:
    119
    Likes Received:
    2
    Trophy Points:
    19
    Location:
    Illinois
    Check your smart junction box for moisture or melting damage.
     
    #4
  5. joe_momma

    joe_momma Member

    Joined:
    Nov 30, 1999
    Messages:
    115
    Likes Received:
    7
    Trophy Points:
    19
    I suspect water in the SJB. Look around in/behind it. Check passenger floorboard area too. While you're at it, check the grommets under the hood (search water leak here). I'd bet it is stopped up, and your cabin air filter is probably nasty to boot.
     
    #5

Share This Page