2006 Mustang GT Knocking...

Trent_97

New Member
Dec 17, 2016
15
0
1
22
I have a 06 GT with around 187,xxx miles I daily drive the car have never really had any issues at all till the past week. Sometimes the car will start knocking when I go to take off "very loud knock" and I will immediately shut the car off and start it back up again and it doesn't knock at all?? I haven't had time to check I was just wondering if anyone could help me pin point this issue?!!!
 
  • Sponsors(?)


Decipha

Active Member
Aug 22, 2007
147
23
29
31
New Orleans, LA
www.murdacapital.com
not enough info

2 things to verify first though

1> make sure your oil is at the full mark and that its golden colored good oil
2> make sure you have a motorcraft oil filter

usually a knocking on acceleration is due to a weak fuel pump on a stock vehicle. Does it give you any trouble cold starting?
 

Trent_97

New Member
Dec 17, 2016
15
0
1
22
not enough info

2 things to verify first though

1> make sure your oil is at the full mark and that its golden colored good oil
2> make sure you have a motorcraft oil filter

usually a knocking on acceleration is due to a weak fuel pump on a stock vehicle. Does it give you any trouble cold starting?
Yes oil is good and ever since I got the car at 127,xxx miles I've always ran motor craft 5w-20 oil and motor craft filter. Sometimes even when it's not cold out I'll go to bump the key over and it wont start then ill do it again and it will be fine, not all the time though.
 

Trent_97

New Member
Dec 17, 2016
15
0
1
22
yea sounds like your fuel pump is dying

best way to verify it is to datalog the fuel pressure. If you have a laptop you can download the forscan software and buy an obd2 cable to datalog and diagnose
I have a sct tuner that can data log I will try it out and see. I'll look up what normal output it should have.
 

Decipha

Active Member
Aug 22, 2007
147
23
29
31
New Orleans, LA
www.murdacapital.com
with the tuner you can log the fuel pump duty cycle.

Its actual value is half of commanded, thus .5 pump dc == 100% duty cycle

If the pump duty cycle gets up over 80% which is 0.40 logged value then you have a problem
 

Trent_97

New Member
Dec 17, 2016
15
0
1
22
It hasn't done it in a couple days, I cleaned my oil pressure sensor where I changed the filter adapter gasket I'm sure there was dirt or oil in it an hasn't done it since.