94 GT MAF/fuel issues

1994gt46

New Member
May 20, 2019
1
0
1
Central MA
New to the forum, but looking for some help. 1994 mustang gt, 5.0L, 5-speed. New long block put in over the winter with new clutch, new radiator and new brake lines. Has a trick flow intake with cold air filter and EGR is blocked off from previous owner. Before the engine replacement, could pull codes and no longer can pull codes but can still read data. Fuel pressure is consistant at 45. Bank 1 & 2 are reading different and the car flattens out. Not sure what the issue is here or where to go from here. Looking to make sure basic things are running 100% before I look into tunes and such.

Thanks!
 
  • Sponsors (?)


RioRed95Cobra

Active Member
Apr 7, 2017
144
10
28
29
It won't let you pull codes? That happened to me when my computer/quarterhorse went funny... I had to reload the tune through the laptop before the fan would turn off and I could run the code reader..

Have you tried just unplugging the battery for an hour or so, clearing the memory, and trying again fresh?
 

jozsefsz

5 Year Member
Aug 11, 2013
1,050
220
94
48
Cleveland OH Area
45 is too high for fuel pressure, should be 39 with vacuum line disconnected, and ~32 with the car idling. unless the car has been tuned for larger injectors than it has (you can simulate larger injectors by increasing fuel pressure).

Bank 1 and 2 what are reading different? O2 sensor output? fuel trim?

Agree you'll want to be able to pull codes. You may have left a harness disconnected or have a damaged wire somewhere.
 

Similar threads