Engine Intake Manifold Upgrade issues

travishalogod

New Member
Oct 7, 2019
4
0
1
31
Southern California
Hi All, very new to this forum but i have read a lot and i haven't seen anything for my exact issue. about 2 months ago my intake manifold cracked (the heater hose receptacle) I tried to install an OEM part that broke on install.. The threads for the plenum literally pulled out of the manifold when i tried to torque to specs. With that happening and all of the reading i did, i ended up purchasing the only all metal intake i could find, the Professional Products Satin Typhoon Intake Manifold from AmericanMuscle... I got it installed and now my idol, throttle, and general running has gone wonky, it is loping. I thought i had a misfire, i don't.. i tested for a vacuum leak, none that i could find. Is it because it changed the fuel/air mixture? how do i fix it? Do i need a tune? The check engine light came on this morning. When i am actually DRIVING its fine. when i let off the throttle and try to slow down it surges forward slightly, not bad but slightly. and it won't slow down once i hit high speed.

I am taking it to a pro this weekend, but i was hoping in the meantime i could get some help. I am taking it today to get the code read but i am sure its a air/fuel
code.
Had the codes checked, doing further research. P1131, P1151, P0113, P0122 Turns out i screwed up on the install pretty badly... over torqued the bolts too.

thank you
 
Last edited:
  • Sponsors(?)


007

Founding Member
Jan 29, 2002
3,279
22
69
Broke
www.steeda.com
Scratch that. Its not the IAC. Your codes all point to an IAT sensor problem. I'd take that out, make sure its connected and mounted fine.

Or vacuum leaks.

P0113 Possible Causes
  • Faulty Intake Air Temperature (IAT) sensor
  • Dirty air filter
  • Intake Air Temperature (IAT) sensor harness is open or shorted
  • Intake Air Temperature (IAT) sensor circuit poor electrical connectio
P0122 Possible Causes
  • Faulty throttle position sensor.
  • Throttle position sensor harness is open or shorted
  • Throttle position sensor circuit poor electrical connection

P1131 FORD Possible Causes
  • Faulty Upstream Oxygen Sensor Bank 1
  • Fuel pressure high or low
  • MAF sensor dirty/defective
  • Vacuum leak on engine
  • Leaking fuel injector or fuel pressure regulator
  • Faulty Powertrain Control Module (PCM)
P1151 Possible Causes
  • Faulty Upstream Oxygen Sensor Bank 2
  • Fuel pressure high or low
  • MAF sensor dirty/defective
  • Vacuum leak on engine
  • Leaking fuel injector or fuel pressure regulator
  • Faulty Powertrain Control Module (PCM
 

travishalogod

New Member
Oct 7, 2019
4
0
1
31
Southern California
Hi there,

I ended up pulling everything off again and inspecting it. No Short or anything and ALL of the issues were caused by two things.

I broke two fuel injectors when i reinserted them so i had to replace that. And then it turns out im an idiot and read the torque setting backwards and over did it the first time around. Luckily there was no permanent damage.

Got it all back together and it works great now.