MegaSquirtPNP 2 problems please help.

95Sn95306

New Member
May 17, 2020
6
0
1
30
New york
Hey guys hoping I can get some help here I just installed this MegaSquirtPNP Nd lc2 wideband afr in my 95 the base tune I downloaded won’t even come close to keeping the car running with out throttling it no matter what I seem to play with I can’t get it to idle all you smell is straight fuel Nd my afr on TunerStudio Nd my gauge both read 7.4-7.5 I have no idea where to start
 
  • Sponsors(?)


a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
10,132
6,022
204
31
Hillsborough county
Did you read any of the manuals?
msextra.com
Have you done the basics and setup the injector and engine size?

The main fuel table VE1 is where you begin
 
Nov 23, 2019
26
6
13
39
Ohio
I think I can help you a little bit with this. i just went through this. My car runs now (somewhat) as I am trying to get my car to get it's timing set correctly. Did you calibrate all of your sensors? TPS, Coolant temp, AFR etc.? Let me know and I can see if I can get you going. I literally fought this for a week with me being such a newbie.
 

Monkeybutt2000

Active Member
Aug 11, 2019
273
205
53
48
Lafayette,IN
I'm going through the exact same thing. I'm just going to let Steve ( a91what) work his tuning magic and take heavy notes. It's a steep learning curve but will be worth it in the end.
 

95Sn95306

New Member
May 17, 2020
6
0
1
30
New york
I’ve read the manuals set up the injector and engine size. Now with the calibration I get to the tps and the no throttle seems to be starting at 291 and flat out wot is 521
 

95Sn95306

New Member
May 17, 2020
6
0
1
30
New york
I’ve been fighting mine for a week or so also and I feel like if I can get it to idle I can use the auto tune and the little I know from YouTube I can get it working well
 

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
10,132
6,022
204
31
Hillsborough county
the TPS is in ADC counts, 1024 counts for a 10bit adc = 0v- 0counts 5v- 1024 counts

thats normal.

I never suggest using autotune for idle VE. autotune will get you close but the majority of the table smoothing and transients have to be done by hand just like any ecu.
Idle and drivability are the two hardest things to get correct, if you look in my sig I have links to videos and other materials to help you.
 

95Sn95306

New Member
May 17, 2020
6
0
1
30
New york
Did you read any of the manuals?
msextra.com
Have you done the basics and setup the injector and engine size?

The main fuel table VE1 is where you begin
the TPS is in ADC counts, 1024 counts for a 10bit adc = 0v- 0counts 5v- 1024 counts

thats normal.

I never suggest using autotune for idle VE. autotune will get you close but the majority of the table smoothing and transients have to be done by hand just like any ecu.
Idle and drivability are the two hardest things to get correct, if you look in my sig I have links to videos and other materials to help you.
 

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
10,132
6,022
204
31
Hillsborough county
my signature under my first post on each page, if you are on a phone it needs to be turned sideways. on the pc you may have to hover to expand it.

It only appears under the first post on each page made by a member so you will have to scroll up.
My stickies are also on the top of the digital tuning forum page.
 
Nov 23, 2019
26
6
13
39
Ohio
I’ve read the manuals set up the injector and engine size. Now with the calibration I get to the tps and the no throttle seems to be starting at 291 and flat out wot is 521
what does your MAP reading in KPA on your gauge cluster?? It should read close to 100KPA (assuming you are running a naturally aspirated car).
 

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
10,132
6,022
204
31
Hillsborough county
even if you are not running an NA car the MAP reading should be around 100kpa in a KOEO condition. The MS2pnp should be using the mapdaddy upgraded sensor [dual sensor with 1bar baro and a 4bar map] in the settings menu it is the MPXH6400

the only time the sensor will read above 100kpa is when the car is seeing pressures above 1ATM.

so every 7kpa is roughly 1psi
14.7psi boost will register 203kpa at sea level.
 
Thread starter Similar threads Forum Replies Date
R Code scanner problem 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 11
P AOD problem anyone with experience? Fox 5.0 Mustang Tech 22
S Electrical wiper problem 1989 LX Fox 5.0 Mustang Tech 10
B 2001 ford mustang/anti theft problem 1996 - 2004 SN95 Mustang -General/Talk- 2
I Throttle body problems Fox 5.0 Mustang Tech 2
D Tire size problem 1965 - 1973 Classic Mustangs -General/Talk- 2
J Tire problem 1996 - 2004 SN95 Mustang -General/Talk- 2
D Tire size problem Classic Mustang Specific Tech 4
R Wheel bearings/problems 1996 - 2004 SN95 Mustang -General/Talk- 9
F Engine 1991 5.0 HO ignition problems. Fox 5.0 Mustang Tech 5
C Overheating problems Fox 5.0 Mustang Tech 9
F Door Lock Actuator OEM Trick/Fix 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 8
G Drivetrain 90 LX Speedo Problem Fox 5.0 Mustang Tech 9
9 Big problem and no idea what to do. Fox 5.0 Mustang Tech 21
S Possible automatic transmission problem? Fox 5.0 Mustang Tech 2
B Megasquirt wideband problem Digital Self-tuning Forum 12
C Microsquirt tuning and surging idle problems Digital Self-tuning Forum 7
General karthief Electrical Ford crate 5.0 engine in a 65 stang / alternater problem Classic Mustang Specific Tech 0
M TR3650 3rd gear problem SN95 4.6L Mustang Tech 1
C ABS problems 1996 - 2004 SN95 Mustang -General/Talk- 16
C Engine Found problem but!! Fox 5.0 Mustang Tech 7
R Painting the interior problems 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 17
D Possible PATS problem? SN95 4.6L Mustang Tech 12
9 95 cobra 5.0 fan problems 1994 - 1995 Specific Tech 3
trlps_ help! fuel problem? 1996 - 2004 SN95 Mustang -General/Talk- 4
MSTNGGRL1995 Rough, loping idle and random attempts to die 1994 - 1995 Specific Tech 1
J 1986 SVO rear break problems Fox 5.0 Mustang Tech 0
1990slow50H Starting issue, electrical problem? Fox 5.0 Mustang Tech 5
K Engine 89 mustang lx 2.3 Starting problems 2.3L (N/A & Turbo) Tech 8
F Electrical New ride - old keyless start problems Fox 5.0 Mustang Tech 4
R Engine Big problems Fox 5.0 Mustang Tech 11
S 72 electrical problems (click no crank) Classic Mustang Specific Tech 1
O start up problems on my 65 with a 302 1965 - 1973 Classic Mustangs -General/Talk- 6
B Electrical 1987 GT turn signal/hazard light problem Fox 5.0 Mustang Tech 1
0 Hey guys, 01 gt having problems really need some help. SN95 4.6L Mustang Tech 8
A Header Problems... GT40Ps 1965 - 1973 Classic Mustangs -General/Talk- 10
D 2005 Mustang Clutch Problems 2005 - 2009 Specific Tech 15
M 1967 s-code fan problem 1965 - 1973 Classic Mustangs -General/Talk- 2
8 Plz Help! ‘88 Mustang will not idle and runs poorly Fox 5.0 Mustang Tech 4
A Fuel Pressure Problem. Need help. Other Auto Tech 10
B Strange Tail Light Problem 2005 - 2014 S-197 Mustang -General/Talk- 0
Esco Fuel Fuel problems Fox 5.0 Mustang Tech 0
13rrgt Gauge problems 2010 - 2014 Specific Tech 0
Jacobhollis New to me Mustang, having problems with key/cranking 2010 - 2014 Specific Tech 1
P cooling fan problems SN95 4.6L Mustang Tech 1
trlps_ 2002 Mustang GT 5spd 5 gear dud gear 1996 - 2004 SN95 Mustang -General/Talk- 4
H Help! No crank problem 1994 - 1995 Specific Tech 1
N Need Help With 1966 Mustang Heater Problem Classic Mustang Specific Tech 8
H Idle problem 2005 - 2009 Specific Tech 9
H A/c PROBLEM think it maybe a compressor Fox 5.0 Mustang Tech 32
Similar threads