Steve's Megasquirt/tunerstudio Help Thread

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
9,757
5,808
204
31
Hillsborough county
@90sickfox I think we may be getting somewhere, when it does idle it looks ok for a cammed engine. I have adjusted the idle settings again to try and slow the surge what ends up happening is the surge shuts the closed loop idle off because the ecu thinks you may be letting out of the clutch.
Capturefoxidlelog.PNG
here is a snip of the entries I use to look at a typical idle log
 

Attachments

  • Like
Reactions: 90sickfox
  • Sponsors(?)


90sickfox

I didn't really have an issue with the stink...
SN Certified Technician
Mar 2, 2015
4,888
4,059
193
42
I'll get that downloaded and try it out tomorrow. Thanx, Steve
 

stang9150

Member
Dec 26, 2005
137
1
18
Steve can you take a look? Pretty new and lost here just got the iac to work somewhat today instead of hanging the idle at 2800rpm. I have major surge until the car gets up to temp even then still some. Car is a 331 with a v3 vortech 13psi non intercooled. I have just been gently driving around back roads no boost at all. I think the surge is coming from the timing table numbers being off. I was going to set them all to the same number but wanted some advice. Timing seems to be good set to 10 degrees and the fuel is set for 60lbs injectors. I would appreciate any insight.
 

Attachments

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
9,757
5,808
204
31
Hillsborough county
Steve can you take a look? Pretty new and lost here just got the iac to work somewhat today instead of hanging the idle at 2800rpm. I have major surge until the car gets up to temp even then still some. Car is a 331 with a v3 vortech 13psi non intercooled. I have just been gently driving around back roads no boost at all. I think the surge is coming from the timing table numbers being off. I was going to set them all to the same number but wanted some advice. Timing seems to be good set to 10 degrees and the fuel is set for 60lbs injectors. I would appreciate any insight.
Before I can do anything with the tune file I need to make sure that you didn't have auto tune on when you took the file. I'm also gonna need to know how you set the timing what method did you use? If the timing at the car on your end doesn't match what I'm seeing on my end serious damage can occur.
 

stang9150

Member
Dec 26, 2005
137
1
18
Auto tune was not active when I saved the file. I did auto tune the other day just to get it driving. I followed the instructions they sent with the pnp box. I set the trigger angle to the number that matched 10 degrees on my balancer.
 

stang9150

Member
Dec 26, 2005
137
1
18
I don't plan on really driving the car hard at all until i get it to the dyno. I just want to be safe for the next few weeks if I want to take the car out for quick drive,not planning on any wot runs.
 

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
9,757
5,808
204
31
Hillsborough county
I don't plan on really driving the car hard at all until i get it to the dyno. I just want to be safe for the next few weeks if I want to take the car out for quick drive,not planning on any wot runs.
Dyno tuning is NOT needed.... just get good datalogs and take it slow. I'll help you with the first revision to get it running better and setup a bunch of tables for you.

For AtoZ tuning shoot me a PM.
 

Blown88GT

Founding Member
Nov 13, 1999
1,850
391
124
Palm Beach Gardens, FL
@90sickfox I think we may be getting somewhere, when it does idle it looks ok for a cammed engine. I have adjusted the idle settings again to try and slow the surge what ends up happening is the surge shuts the closed loop idle off because the ecu thinks you may be letting out of the clutch.
Capturefoxidlelog.PNG
here is a snip of the entries I use to look at a typical idle log
Your VE Table doesn't match the others for boost, 170 vs 200.
Advance Table seems a little high in the idle range, try 16.
 

90sickfox

I didn't really have an issue with the stink...
SN Certified Technician
Mar 2, 2015
4,888
4,059
193
42
This thing keeps getting better and better. I haven't had the time to look through the log yet but here it is. A lot is going on t5his weekend so I'm trying to get time with the car when I can. When I first started the car the TPS wasn't calibrated. I had to reset it again from 5.? percent back to zero. I don't know if that shows up in the log. This is the best this thing has idled. Steve, again, you are the man. I'm going to go back and review all these logs and tunes to get a better understanding.
 

Attachments

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
9,757
5,808
204
31
Hillsborough county
DIY base map for stock 5.0 is 16.
My vacuum is 18-20, maybe because of the flow from the S/C. My BOV doesn't vent 100%.
not every car wants the same thing, the 20* I am referring to is the map from the a9l most use. as an example the diy base tune wot timing is 31* the a9l wot timing is 28* I suggest running 91 octane if you do not adjust the ign table

cammed engines are lucky to achieve 14" hg the lope of a cam like his is what makes the idle tuning difficult.
 
  • Like
Reactions: 90sickfox

90sickfox

I didn't really have an issue with the stink...
SN Certified Technician
Mar 2, 2015
4,888
4,059
193
42
The car runs a little better. The idle surge is still there but I noticed something in the AFR1 table. The cells seem to have a big difference and the scaling doesn't go below 1000. Do you think I should lower the scale to 800rpm and smooth out the AFR1 table.
 

Attachments

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
9,757
5,808
204
31
Hillsborough county
The separation between idle cells and cruise cells is small. That is the reason for the "large change". Under everything is interpolated so the steps in between cells are a nice smooth ramp to the next.... the AFR in the 1000rpm cell is the same for all numbers below 1000.

In the logs you send me I notice you cruising at low rpm hence the AFR in the 1400rpm cells. You want to be near stoic in this area or leaner but at idle you need to be slightly rich 13.5 or so.
 

90sickfox

I didn't really have an issue with the stink...
SN Certified Technician
Mar 2, 2015
4,888
4,059
193
42
When idling I noticed when the rpm surge us happening the dot is bouncing from 14.8 at 1200rpm to 13.5 at 1000rpm. and below. Seems like when idling it bounces between those cells at 55kph. ( if that is even kph. Lol ).

I'm just trying to figure out some of this stuff so I can get a grasp on tuning on my own. My idle is surging around a bit from 792 to 1516rpm at times. I appreciate all the help, man.

If I could get this thing to idle smooth it would be great. Guess we're heading in that direction. :nice:

The rev was sitting still and holding the pedal at about 6% tps. I wanted to see what it looked like at that point. No cruising yet.
 

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
9,757
5,808
204
31
Hillsborough county
Main issue Scott is that your idle is unstable even with the iac unplugged... in reality Scott you need to get the car to idle steady with it unhooked. Find the rpm that the idle is stable and adjust the 've table and timing table until the vacuum is highest. It's easiest to do standing in front of the car. Higher vacuum is lower kpa value.
 

90sickfox

I didn't really have an issue with the stink...
SN Certified Technician
Mar 2, 2015
4,888
4,059
193
42
OK will do, Steve.

Have you ( or anyone else here ) used MSDroid shadow gauge ? I downloaded the app to my phone. Seems to work but haven't hooked up to my MSPNP2 yet. I'll be using USB, no Bluetooth.