03 Mustang Gt Cooling Fan Issues

Discussion in 'SN95 4.6L Mustang Tech' started by skimi, May 30, 2013.

  1. skimi

    skimi New Member

    Joined:
    May 30, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hi, i'm new here and i really need your help. my cooling fan won't turn on at all. I thought it might be the ccrm, replaced that still the same. The i replaced the cooling temperature sensor, still the same. Checked the fuses they are ok. So what should i do next? Thanks...
     
    #1
  2. COramprat

    COramprat Drone Driver
    Mod Dude

    Joined:
    Mar 3, 2003
    Messages:
    6,279
    Showcase:
    21
    Albums:
    2
    Likes Received:
    155
    Trophy Points:
    113
    Location:
    Sea of Tranquility
    See if you can turn the fan blade. Could be the bearings went bad. You can jump the fan connector to the battery and see if it is working. Get a Chiltons Manual...it will have the wiring diagrams and tell you which prongs are ground, low speed and high speed...or wait until I get home tonight and I'll look in my book.
     
    #2
  3. Rusty67

    Rusty67 Well-Known Member

    Joined:
    Dec 3, 2002
    Messages:
    3,618
    Likes Received:
    13
    Trophy Points:
    59
    Location:
    SB, CA
    Do you have a mutlimeter ? You will likely need one to hunt down the issues. Did you check the fuses visually or did you actually test them with a tester ? Fuses can look good but be bad. You have to use a tester to make sure.

    Check the fan to make sure it operates as COrampart sugests and then work backwards from there. You may need wiring diagrams which google can provide. If you can't find what you need someone here can likely get you what you need. A Chiltons manual isn't a bad idea either since you wont need a computer near by to look at it.
     
    #3

Share This Page