Engine Maf Symptoms

Discussion in 'Fox 5.0 Mustang Tech' started by Zebanks, Sep 18, 2013.

  1. Zebanks

    Zebanks New Member

    Joined:
    Sep 18, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    2
    I have a 1989 5.0 and its not running right. it has the signs and symptoms of a dirty maf. But I cleaned it and I cleaned my air filter and it still has a rough idle and dies when I start it up if I don't give it as to keep it running. So what else could it be? Thanks
     
    #1
  2. Noobz347

    Noobz347 Stangnet Facilities Maint Tech... Er... Janitor
    Admin Dude

    Joined:
    Jan 5, 1985
    Messages:
    20,778
    Showcase:
    59
    Albums:
    8
    Likes Received:
    2,732
    Trophy Points:
    174
    Location:
    Box behind Walmart
    Pull Codes:


    Courtesy of Jrichker:

     
    #2
  3. madspeed

    madspeed Colonel Mustard
    Mod Dude Founding Member

    Joined:
    Nov 30, 1999
    Messages:
    8,736
    Showcase:
    9
    Albums:
    1
    Likes Received:
    1,292
    Trophy Points:
    174
    Location:
    a van down by the river
    @Noobz347 maybe we should just sticky a" Any engine related issues... ALWAYS PULL CODES thread :rolleyes:
     
    #3
  4. mikestang63

    mikestang63 Mustang Master

    Joined:
    Aug 28, 2012
    Messages:
    4,283
    Showcase:
    20
    Albums:
    1
    Likes Received:
    1,251
    Trophy Points:
    154
    Location:
    In the garage
    Noobz, remember your recent post about moderating newb posts, especially the ones where the question has been asked a thousand times? :stick: ahem.............
     
    #4
  5. madspeed

    madspeed Colonel Mustard
    Mod Dude Founding Member

    Joined:
    Nov 30, 1999
    Messages:
    8,736
    Showcase:
    9
    Albums:
    1
    Likes Received:
    1,292
    Trophy Points:
    174
    Location:
    a van down by the river
  6. Casey2552

    Casey2552 Member

    Joined:
    Sep 16, 2013
    Messages:
    88
    Likes Received:
    2
    Trophy Points:
    9
    Location:
    Taylor,mi
    That's a little rude , if ya want answers pull codes first then people here will be able to help better , but sounds like iac valve problem
     
    #6
  7. Noobz347

    Noobz347 Stangnet Facilities Maint Tech... Er... Janitor
    Admin Dude

    Joined:
    Jan 5, 1985
    Messages:
    20,778
    Showcase:
    59
    Albums:
    8
    Likes Received:
    2,732
    Trophy Points:
    174
    Location:
    Box behind Walmart

    The thing is that it could be 1 (or more) of any number of things. It's not rude to try and find ways to state the obvious. Lots of folks try and avoid the "spit ball" approach and attempt to narrow it down some. Pulling codes is a good first step.
     
    #7
  8. Noobz347

    Noobz347 Stangnet Facilities Maint Tech... Er... Janitor
    Admin Dude

    Joined:
    Jan 5, 1985
    Messages:
    20,778
    Showcase:
    59
    Albums:
    8
    Likes Received:
    2,732
    Trophy Points:
    174
    Location:
    Box behind Walmart
    This actually isn't a bad idea. We could put up a sticky with @jrichker 's instructions on how to pull them. It might save folks some time when they're trying to diagnose a problem.
     
    #8

Share This Page