94 Vert Gt Cobra Engine Plus Manual Swas Help

Recvery

Member
Jun 27, 2016
19
2
13
28
What's up stang net peeps?!

since the last time I posted here on stang net I've collected two more mustangs. a 94 V6 with an unfinished cobra engine and t5 swap that I have since pulled out and as of today dropped into a 94 mustang gt convertible with an auto trans.

I pulled the Cobra out yesterday and dropped it into the gt today. everything went smooth and tomorrow morning I'll finish everything up and hopefully it's runs smoothly.

My only dilemma here is what ecu to use. I have the ecu that's currently in the gt, which the previous owner installed a megasquirt or something similar. anyhow theres a cord coming out of the dash that looks like an amps remote gain wire. trouble is its an auto ecu and theres now a t5 in the car. Is it possible to use the tuner to make the it work seemlessly with the manual trans? or should I stick with the cobra ecu? (I have two of these)

 
  • Sponsors(?)


90sickfox

Wasn't a pretty sight...and I've got big hands
SN Certified Technician
Mar 2, 2015
5,803
4,897
203
43
That attachment won't work for me. I can say that my Megasquirt mspnp2 doesn't care whether stick or auto. Wish I could see the pic. Is there a name on the ecu ?

I'm not sure about the 94 ecu or the differences. I know there are a few. If the cobra ecu is for a 5 speed I'd use it to get it running first. That way you'll know what you've got. Putting the aftermarket ecu in first could cause you to chase your tail.
 

Recvery

Member
Jun 27, 2016
19
2
13
28
The cobra ecu is for a 5 speed (what I was told) and started the car, ran and drove with reverse lights, but had a high idle like 2500 rpms. but the ecu that was in the gt first! had a black box plugged into the oposited side of the main plug on the ecu.it also ran the car but with the same high idle. can you tell me which parts you need specifics on??
 

Recvery

Member
Jun 27, 2016
19
2
13
28
I didn't see a name ok n the ecu either but was really looking for one. i check tomorrow morning
 

Recvery

Member
Jun 27, 2016
19
2
13
28
As for my high idle issue, the usual suspects are vacuum or maf right?

I routed the vac as follows

From the intake two of the three ports on the drivers side of the intake tie together and go to the pcv. the third drivers side port is going to the purge valve on the passenger side.

The large port on the pass side is going to the vac tree , and one of the smaller ports goes directly to the fuel press reg. and the last port is capped off.

Sound right???
 

90sickfox

Wasn't a pretty sight...and I've got big hands
SN Certified Technician
Mar 2, 2015
5,803
4,897
203
43
Did your try setting the timing and the tps voltage ? Sounds like a vacuum leak but it would have to be pretty big to idle up that high. You could plug all the lines and see if idle comes down.
 

Recvery

Member
Jun 27, 2016
19
2
13
28
Did your try setting the timing and the tps voltage ? Sounds like a vacuum leak but it would have to be pretty big to idle up that high. You could plug all the lines and see if idle comes down.
I tried plugging each one and then the sources but it didn't help. I haven't checked the tps and or the timing. I suppose I need to break out my multi meter and check tps voltage, then adjust it by turning it?

As for timing, I have a basic light so I'll do that tomorrow as well. do you happen to know the basic timing procedure and what my tps should read??
 

90sickfox

Wasn't a pretty sight...and I've got big hands
SN Certified Technician
Mar 2, 2015
5,803
4,897
203
43
@jrichker . Correct. There's is a idle checklist here on Stangnet. The before mentioned guy wrote it. His posts are long ( sometimes ) but worth the read. Follow his steps and your car will thank you for it. [emoji12]
 
  • Like
Reactions: 1 user

Recvery

Member
Jun 27, 2016
19
2
13
28
@jrichker . Correct. There's is a idle checklist here on Stangnet. The before mentioned guy wrote it. His posts are long ( sometimes ) but worth the read. Follow his steps and your car will thank you for it. [emoji12]
I'm gonna follow that checklist in the morning. I did want to bring up one other thing incase it points out something obvious. I remember unplugging the maf, the tps, the iac and it didn't change the way the engine ran at all. could It be a ground I'm missing?
 

90sickfox

Wasn't a pretty sight...and I've got big hands
SN Certified Technician
Mar 2, 2015
5,803
4,897
203
43
I'm gonna follow that checklist in the morning. I did want to bring up one other thing incase it points out something obvious. I remember unplugging the maf, the tps, the iac and it didn't change the way the engine ran at all. could It be a ground I'm missing?
It could be....go over everything you did....usually its some small thing that's over looked.