Microsquirt with strange cold start problem

92Foxvert

New Member
May 9, 2019
3
0
1
35
Prince Frederick, MD
I'm having issues with cold start and warm up. I have a microsquirt from efi source. I'll start by listing my engine details
1992 5.0
speed density
gt40p heads
explorer intake with IAT sensor in #5 runner
GM IAT and CLT
Anderson N41 cam
Ford 24lb injectors
AEM 30-4110 wideband
Timing verfied with timing light
180F T-stat

I've been working on this project for a few months now off and on. It idles great warm, good drivability, and pulls nicely. I had warm up dialed in closed loop, then build my closed loop following a91what's channel. I thought i was getting somewhere, but then today it started acting strange on cold start. My idle advance kicks in at 100F, but before then, it is all over the place. The strange part is, during initial warm up, my timing is jumping around and i don't know whats triggering it. When I check my rpm and map in data-logs, it does not match what my ignition table is calling for. My timing should be flat at 18 from 850-1200 rpm, and its jumping high as 20, and low as 14, but i cant figure out were some of these values are coming from. Also, something is triggering ASE again after the engine is already started. Once the engine gets to about 100F and the idle advance come on, everything settles out. I could not find anything that stands out that would be causing this. I know im a bit lean when cold, but autotuning WUE when this is happening goes all over the place. It doesn't seem to be closed loop related from what i can tell. I have not had a chance to switch back to open loop. Its so warm here, i don't get many opportunities to start it cold. I can get my garage down to 75-80 at the coldest.

I've tried getting myself to this point without posting to ask silly question, but this one has me stumped. Ive attached my tune and datalog of a cold start, if someone could take a look, it would be greatly appreciated. I was completely new to tuning 2 months ago and have come a long ways, but im sure there are things that are off. I will appreciate all help and suggestions. Thanks guys
 

Attachments

  • Sponsors(?)


a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
9,580
5,760
204
31
Hillsborough county
Ok so in the datalog i can see that she clearly needs more fuel on a cold start, The AFR is very lean and a lean engine will not idle well cold. I also looked at the spark advance and i do not see it dip below 18 but i do see it go above as you have set in the base spark table when the idle speed starts to drop. When she hits 100 the idle advance kicks in and forces the engine to idle stopping the lean surge.
My suggestion for now is to increase the WUE values from 140* and below, add 8% at 100* and below and taper it as the engine warms up. The engine needs to be about .7 richer than target on warmup. You should also go into the general settings and reduce the lambda lag factor by 20-30% to clean up the AFR signal into the MS.
 
Jun 15, 2019
64
5
18
46
lake george, ny
Ok so in the datalog i can see that she clearly needs more fuel on a cold start, The AFR is very lean and a lean engine will not idle well cold. I also looked at the spark advance and i do not see it dip below 18 but i do see it go above as you have set in the base spark table when the idle speed starts to drop. When she hits 100 the idle advance kicks in and forces the engine to idle stopping the lean surge.
My suggestion for now is to increase the WUE values from 140* and below, add 8% at 100* and below and taper it as the engine warms up. The engine needs to be about .7 richer than target on warmup. You should also go into the general settings and reduce the lambda lag factor by 20-30% to clean up the AFR signal into the MS.
ok ill have to look at that to see how to change it.... i did add a little ve so it would idle better on warm up..... she goes way phat on brake to launch
 

Attachments

92Foxvert

New Member
May 9, 2019
3
0
1
35
Prince Frederick, MD
Ok so in the datalog i can see that she clearly needs more fuel on a cold start, The AFR is very lean and a lean engine will not idle well cold. I also looked at the spark advance and i do not see it dip below 18 but i do see it go above as you have set in the base spark table when the idle speed starts to drop. When she hits 100 the idle advance kicks in and forces the engine to idle stopping the lean surge.
My suggestion for now is to increase the WUE values from 140* and below, add 8% at 100* and below and taper it as the engine warms up. The engine needs to be about .7 richer than target on warmup. You should also go into the general settings and reduce the lambda lag factor by 20-30% to clean up the AFR signal into the MS.
I made changes to my WUE as suggested, and reduced my lamda lag factor. I will do a cold start when i get home and report back. Also with the timing, i attached screenshots of the parts that confused me. The first pic is where the timing dropped to 16.69 right before ASE kicked in again. The second screen shot is where my timing is at 19.98 at 1057 rpm. Neither event seems to match what my ignition table is calling for. Am I looking at this wrong or missing something?

Screenshot (1).png
Screenshot (2).png
 

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
9,580
5,760
204
31
Hillsborough county
Remove the smoothing on spark. [S5] is significant smoothing... I only smooth rpm and map sometimes afr if I am just doing a casual review. For picking out issues you want very little to no smoothing.
 

92Foxvert

New Member
May 9, 2019
3
0
1
35
Prince Frederick, MD
Remove the smoothing on spark. [S5] is significant smoothing... I only smooth rpm and map sometimes afr if I am just doing a casual review. For picking out issues you want very little to no smoothing.
Thanks for that Tip! Once i changed that, what i was viewing made much more sense. I didn't realized how much smoothing affected accuracy. I've only been able to start it once since your suggestions. It defiantly improved. Now that i'm reading the log viewer properly, i should be able to work things out from here.

Also, I would like some feedback on my spark table if you or anyone else wouldn't mind. I put it together from studying other peoples tables and the A9L WOT curve. I've never been confident with it because most examples are from boosted cars, but I tried to make my WOT match what i had with the factory computer. Its everything below that, and my transition from idle (900) to 2150 rpm that i'm unsure of.
 
Thread starter Similar threads Forum Replies Date
K The ole new guy cant tune bit.. 88 5.0 fox microsquirt Digital Self-tuning Forum 2
T Quick question microsquirt Digital Self-tuning Forum 6
I Microsquirt idle after clutch engagement Digital Self-tuning Forum 1
S Another Idle surge post with microsquirt Digital Self-tuning Forum 5
J Microsquirt vs ms3gold box? Digital Self-tuning Forum 6
C Microsquirt tuning and surging idle problems Digital Self-tuning Forum 7
A Microsquirt setup and first start questions Digital Self-tuning Forum 10
U My microsquirt project Digital Self-tuning Forum 4
matt_ru Microsquirt with MSD 6A help Digital Self-tuning Forum 24
T Microsquirt and inputs Digital Self-tuning Forum 3
beyondEOD SN95 94-95 Microsquirt Pinouts Digital Self-tuning Forum 8
79pace Moates / TwEECer / MicroSquirt? Which one should I look into? Digital Self-tuning Forum 16
beyondEOD Fuel Pressure Sensor with Megasquirt Digital Self-tuning Forum 15
Jtoepper93 Turbo fox microsquirt help Digital Self-tuning Forum 16
beyondEOD 94-95 Mustang 5.0 AODE MS3 Gold Box w/ Microsquirt Digital Self-tuning Forum 62
beyondEOD 94-95 Mustang GT Auto Dual Microsquirt ECUs Digital Self-tuning Forum 14
S Microsquirt issue. Car won't start with SPOUT in Digital Self-tuning Forum 8
G Electrical Microsquirt harness help Fox 5.0 Mustang Tech 9
J My first microsquirt project Digital Self-tuning Forum 13
Nightstang00 Digital Tuning Coolant Temperature Sensor Microsquirt Fox 5.0 Mustang Tech 13
6 Help Need for a 4 cylinder swap with a microsquirt!!!!! Digital Self-tuning Forum 5
A Any help with Microsquirt tuning would be very much appreciated Digital Self-tuning Forum 14
94tang Fried Microsquirt? Digital Self-tuning Forum 7
maisonmays22 Microsquirt no start condition Digital Self-tuning Forum 31
maisonmays22 Microsquirt General Questions Digital Self-tuning Forum 1
E Stock 94 GT Microsquirt wont run/idle Digital Self-tuning Forum 2
OldManRiver Microsquirt V3-No start with spout in Digital Self-tuning Forum 15
Nightstang00 Idle issues with a foxbody and microsquirt Digital Self-tuning Forum 31
a91what Service Provided Megasquirt ECU support and Tuning Services - Tuning, Welding, Mechanic, Body Work... 5
A Ignition box with microsquirt Digital Self-tuning Forum 3
Gunny87 Microsquirt not syncing up with tunerstudio Digital Self-tuning Forum 11
8 5.0 microsquirt mustang hits wall around 5000 RPM Digital Self-tuning Forum 25
Creomod SOLD Microsquirt for sale new mustang 86-93 Other Classifieds 3
U 5.0 Microsquirt start up help Digital Self-tuning Forum 11
8 5.0 microsquirt help Digital Self-tuning Forum 18
Blucifer99 92lx. Whats the difference between microsquirt and megasquirt for fox mustangs Digital Self-tuning Forum 10
1 97 explorer 302 microsquirt Digital Self-tuning Forum 41
danielhv danielhv 87 microsquirt project Digital Self-tuning Forum 78
H 1989 gt vortech supercharged microsquirt, having trouble getting idle set, need a tune to compare. Digital Self-tuning Forum 4
a91what Megasquirt/tuner Studio Tech Thread Digital Self-tuning Forum 16
K Strange ticking noise Fox 5.0 Mustang Tech 17
Teddyd 1985 fuel pump issue? sounds strange Fox 5.0 Mustang Tech 6
A Strange clutch fork issue SN95 4.6L Mustang Tech 0
screamin gt Strange brake noise, hot front brakes 1996 - 2004 SN95 Mustang -General/Talk- 5
P Drivetrain 1995 GT Auto Transmission Acting Strange 1994 - 1995 Specific Tech 1
S Strange sound coming from under car? 2001 Mustang GT 1996 - 2004 SN95 Mustang -General/Talk- 1
B 2011 - Strange lock / unlock behavior with key fob. 2010 - 2014 Specific Tech 4
B Strange Tail Light Problem 2005 - 2014 S-197 Mustang -General/Talk- 0
S Suspension Strange sound while driving. Sounds like cards in bike spokes. Fox 5.0 Mustang Tech 5
9 Need held, Strange Sound at Ignition Fox 5.0 Mustang Tech 2
Similar threads