New guy with a few questions

1987fox5.0

New Member
May 13, 2010
26
0
0
Just got my first stang. A 87 fox body 5.0. Just bought it today, While driving it home I noticed a few things I never noticed when I first looked at it.

One the steering collum seemes really loose

Also I tured the wipers on just to see if they worked then I couldn't get the delay to turn off, its almost like the lever isn't twisting all the way off?

Not sure if this is where to post these kind of things but any help would be appreciated! Thanks!
 
  • Sponsors (?)


stykthyn

I want to measure mine. It doesn't look that tall.
10 Year Member
Jul 6, 2006
5,297
2,726
223
gainesville
Posted via Mobile Device
the wiper probably just needs a new multi switch. thats a pretty common problem. for the steering i would follow the column into the engine bay and see if anything is loose. if so tighten the bolts back down and see if its any better. if that doesnt fix it you may need a new tilt column. not hard to replace if thats what it comes to.

oh yeah. PICS!!
 

1987fox5.0

New Member
May 13, 2010
26
0
0
I posted a pic of the car, where would be the best place to get a multi switch? I found one on american muscle but they want 300 bucks for one, seems like alot
 

1987fox5.0

New Member
May 13, 2010
26
0
0
also I noticed in a few spots the clear looks like its starting to peel, any ways to fix that with out clearing the whole car?
 

stykthyn

I want to measure mine. It doesn't look that tall.
10 Year Member
Jul 6, 2006
5,297
2,726
223
gainesville
I posted a pic of the car, where would be the best place to get a multi switch? I found one on american muscle but they want 300 bucks for one, seems like alot
sorry I was on my phone and for some reason it didnt show the pic. looks good :nice:
 

1987fox5.0

New Member
May 13, 2010
26
0
0
Bingo puuled the collum apart and those 2 bolts were loose, tightend them up, also I grabed a multi switch from a 93 but the wipers dont work at all, the lights and everything do but not the wipers, also my fuel guage is really weird. It reads fuul untill I get about half a tank then it goes to half, then back up to full?

Also my temp guage doesnt work where should I look to fix that?
 

stykthyn

I want to measure mine. It doesn't look that tall.
10 Year Member
Jul 6, 2006
5,297
2,726
223
gainesville
if you can find a stang in the yard there is a little circuit board called the anti-slosh module that goes bad. it pulls right out. get one of those if you can. If that doesnt fix your gas reading then your fuel sending unit is shot.
Temp gauge probably needs a new sender. its located on the lower intake on the driver side.
 

1987LXragtop

Member
Jan 26, 2008
837
3
18
Just outside Philly PA
Check to see if the rag joint is shot on the steering shaft. If it is anything like mine was then that could easily solve your loose steering. As far as clear...the only way to do it right is to re clear the car. It looks nice from the pic so you should do it right. Oh and Im with the rest of them . More Pics!!!
and welcome to the jungle.
 

old_blue

10 Year Member
Nov 3, 2003
1,813
307
124
Are you sure you are turning the wipers off. Not to sound like an azz but the lowest setting on the wiper delay and the off position are on opposite sides of the switch. There is not another setting past the low delay for off. you have to turn it the other way. Off is between fully on and the delay start positions. should read HI -LO- 0 - then the delays. make sure it is on the 0 and it will be off. hope that helps. if not then just ignore me
 

old_blue

10 Year Member
Nov 3, 2003
1,813
307
124
FYI I found this out when I bought my first fox 10 years ago driving home in the rain at night. never had a car that did that before so it was strange to me.


ph and your car looks clean. Makes me miss my 89 LX.
 

1987fox5.0

New Member
May 13, 2010
26
0
0
My wipers and everything work now, at first I wasnt turning them all the way off duhhhh and the steering is fixed aswell.
 

old_blue

10 Year Member
Nov 3, 2003
1,813
307
124
sweet, My steering was like yours when I first got it. Tightened up the two bolts and it has been perfect ever since. Everytime I look at you hatch makes me want another one. I know if I get rid of my coupe I would miss it though.
 

Strippt88

New Member
Nov 24, 2006
81
0
0
Cedar Lake, Indiana
Nice car, welcome brother! You will need a couple parts catalogs- Year One, 5.0 Resto (also known as Latemodel Restoration Supply), Texas Mustang Parts to name a few. They haver the tools and the talent.
 

1987fox5.0

New Member
May 13, 2010
26
0
0
Thanks for all the replies! New probleem tho took the car for dinner today and came out to find a puddle of coolant underneath it. The car has an electric fan and i'm 99% sure its not working, I'm assuming its hooked up to a thermostat on my temp guage thats also not working. I was thinking of just wiring the fan to a switch. I also noticed on the way to dinner the car was idleing high(1500rpmish) and on he way home it was fine(900ish) I think it just got really hot and boiled over some coolant. What you guys think?