please help my mustang wont come out of limp mode

horse sence

That $5 hooker turn out to be a guy
15 Year Member
Nov 29, 1999
10,242
5,370
233
Wile Coyote's stunt double
Mine is pumping water out the exhaust like crazy ,but it isnt from the motor ,it is steaming inside the exhaust system ,anyone standing behind it when i start it gets coated in black water from it being so rich . I was told it still could be the oxy. Sensor ,it may be reading but not heating up . Going to ford monday to get ford sensors ,there isnt much left that i havent changed
 
  • Sponsors(?)


Mar 9, 2022
19
2
13
17
mobile al
Mine is pumping water out the exhaust like crazy ,but it isnt from the motor ,it is steaming inside the exhaust system ,anyone standing behind it when i start it gets coated in black water from it being so rich . I was told it still could be the oxy. Sensor ,it may be reading but not heating up . Going to ford monday to get ford sensors ,there isnt much left that i havent changed
do you have bad exhaust leak?
 
Mar 9, 2022
19
2
13
17
mobile al
i have an s197 2008 mustang gt with multiple codes, p0141 and 161, p0152,p061b,p1000,and p2196 and 2198.
i have replaced o2 sensors on bank 1 and 2 (the front ones, i am gonna purachase mil eliminators for the cats 02s) i have replaced the throttle body, i have replaced the air filter with a nice knn stock filter. the problem i have is when i start the car it sounds kinda like its misfiring and when i let the clutch off and give it gas will die then jolt to 2k rpms and go (doesnt happen everytime though). the car will die when trying to start (not all the time but happens frequently). the car will be alright for a few minutes of driving but after awhile the wrench light will pop and i loose engine power. its not exactly limp mode though its more like a cut in power. can someome please show me what i need to fix? ive been trying to fix this for a month now.
ive found the issue, the maf sensor totally failed!
 
  • Useful
Reactions: 1 user

horse sence

That $5 hooker turn out to be a guy
15 Year Member
Nov 29, 1999
10,242
5,370
233
Wile Coyote's stunt double
Thing is i pulled this motor from a wrecked 2007 and it ran perfect while in the wrecked 07 . I kind of think it is somthing in the 05 it is in now ,but i changed the computer with the 07 ,plugged the 07 key in the reader and started it and it still ran the same so it cant be the computer
 
Mar 9, 2022
19
2
13
17
mobile al
Thing is i pulled this motor from a wrecked 2007 and it ran perfect while in the wrecked 07 . I kind of think it is somthing in the 05 it is in now ,but i changed the computer with the 07 ,plugged the 07 key in the reader and started it and it still ran the same so it cant be the computer
have you tried all the simple stuff? like maf sensors and fuel filters and all that?
 

manicmechanic007

Mustang Master
Sep 26, 2017
1,525
433
93
62
Just so all of you know
The byproducts of complete combustion are H2O and CO2
That is why you will see carbon pounds per mile specs for new cars in Motor Trend et al.
Nobody worries about water but the carbon dioxide numbers have the enviros going nuts
Gas weighs roughly 6 pounds a gallon and hydrogen is nil for weight
Means every gallon of gas burnt helps the plants on earth by almost 6 pounds of life nourishing CO2
 
  • Clever
Reactions: 1 user

manicmechanic007

Mustang Master
Sep 26, 2017
1,525
433
93
62
Horse sense, You know how to check the cats for being plugged with a vacuum gauge right?
If it is in limp mode it will run rich
The ecu grounds check first
* We used to have a shoddy I/M place down the road from the dealer where I worked
The A holes would take the bolt out of the front of a Taurus 3.0 head holding the processor ground
That made the car run 5.0 on the CO and blow black smoke. Soot out the exhaust the works
School of hard knocks figuring that one out. They did it constantly.
Got their tit in a ringer eventually with the State I/M boys