Digital Tuning 1995 Mustang Gt, No Start

Discussion in '1994 - 1995 Specific Tech' started by 95steeda, May 11, 2012.

  1. Okay, I rebuilt the 302 in my Mustang. Got everything hooked up, and started it. It was runnning for about 5 min, although not very smooth. I was running old gas through it, about 2.5 years old. Then, all of a sudden, it died. After that, it would not start again.
    I checked fuel pressure, 0psi. So, I dropped the take, removed all the old fuel and replaced the fuel filter. Now I have 37 psi with key on.
    Still no start.
    Checked for spark at coil with a spark tester, no spark.
    So, I stepped through the no start checklist.

    A) NA
    B) Installed new distibutor, checked timming. No start
    Removed SPOUT. No start
    C) Installed new TFI module. No start (old one tested fine)
    D) Replaced coil. No start
    E) Verified 12v at injectors
    F) Verified fuse was good
    G) Verified 12v at coil
    H) Verified ground (orginally had a problem here, if this is not connected, it wont turn over)
    I) have not verified computer
    J) Not sure where this ground is located. Is there a ground wire from a harness, or does it just ground the firewall to the battery? It was running and starting and the gauges do work, so I think this is okay, but would like to verify.
    K) Does not fire briely

    I also verified 12v to TFI and set TPS to .976 from .922.

    All that said, where should I go next?
    How can I verify the EEC is working? I would think it is since I have power to everything.

  2. Update:
    Rechecked TPS, from control pin to negative battery terminal .976 volts. From control pin to the plug ground pin that goes to the EEC, .420 volts.
    High resistance in the wire??? Could this cause it not to start?
  3. Possibly. If the ecu is seeing .42v it's outside of the expected range. Since it could be a dozen or so causes I would suggest that you check to see what DTC's have been stored by the ecu. What did the ecu reference voltage to TPS read? It should be close to 5v.
  4. Update:
    The low TPS voltage was erroneous. My back probe pin was loose, giving a low reading. Actual voltage is fine.

    The reference voltage is 4.8.
  5. Update:
    The only DTC I have is 564. Thats expected since I don't have the A/C stuff hooked up yet.
  6. Update:
    So i unplugged the TFI, and grounded the Coil - pin in the harness, and got spark at the Coil. So the coil is fine.
  7. So that leaves air and perhaps the fuel filter. Didn't see where that was changed. Clean air filter? Are you pulling any vacuum while cranking?
  8. Well, the problem is I have no spark when cranking. I have it when I manually ground the coil pin on the TFI harness.
    Yes, the fuel filter was changed when I dropped the tank to drain the old fuel. The filter was clogged, which is why it stopped running in the first place (I believe). I had 0 pressure at the rail. Once I changed the filter and fuel, I had proper pressure, just no spark.
    Yes, the air filter is clean. It's a K&N, I recharged it before I put it on.
    I have not checked vacuum, but I wouldn't figure that would prevent spark.

    I am checking for spark with a spark tester in between the coil and the dizzy cap.
  9. Solved.
    After getting spark when I ground the pin in the TFI, I figured the TFI must not be getting a signal. So I checked the TFI wiring harness and found the problem. Starts and runs now. Thanks for the help.
  10. Broken wire or bent pin? Your first post says it was replaced.
  11. Yes, the TFI was replaced, and the old one tested good.
    Apparently, it was a short. I had a section of wire loom removed about 10 inches up the wiring harness. I removed it to trace a wire when it wouldn't turn over (details in a seperate post). There is a wire thats wrapped in aluminum sheilding, and it seems that it was touching some metal. The only thing I can figure is it prevented the TFI from properly grounding. I put the loom back on, and it fired right up.
    I have since checked the continunity of the wires and they all seem fine.
    It's a 1995, so it has the remote TFI that sits on the passenger side of the engine compartment.
    Thanks for the help. Now its on to figure out why the alt isn't charging the battery.