Progress Thread Left me stranded, again... just luckily it was in the driveway.

BlakeusMaximus

Still got to try a little lube on my speedo head
Jul 12, 2017
1,965
1,105
153
Sure is a lot of wires! I can see why that was tricky. Gauges look good Devil! Take a picture of them in the dark.
 
Last edited:
  • Like
Reactions: Reddevil91
  • Sponsors(?)


90sickfox

I didn't really have an issue with the stink...
SN Certified Technician
Mar 2, 2015
5,221
4,296
203
42
The best spot I've found to run wire into the engine bay is through a grommet behind the left fender. It's very hard to get to. I always remove the whole fender... but you may be able to reach it by removing the fender liner and wheel. If you look in the hinge area you might see it.

I ran a couple extra wires through mine so I wouldn't have to take the fender off to run more. Just rolled them up and hid them behind the drivers strut tower / booster area.
 
  • Like
Reactions: Reddevil91

Reddevil91

10 Year Member
Mar 3, 2010
1,318
517
153
Sure is a lot of wires! I can see why that was tricky. Gauges look good Devil! Take a picture of them in the dark.
Ha will do, trying to get this all done by this weekend so I’ll post up some better pics once I get the dash all back together.
 

Reddevil91

10 Year Member
Mar 3, 2010
1,318
517
153
Sure is a lot of wires! I can see why that was tricky. Gauges look good Devil! Take a picture of them in the dark.
Honestly it was actually pretty easy once I got over the wiring fear last night and just went for it. The majority of it was all just plug and play connect the dots except those oil and water which I just ended up using the included male plug then heat shrunk them and plugged them into the ground, 12v, and illumination feeds already in the wire loom, same for the led indicators and plugged them in to their correct wires. It actually came with a detailed explanation so you know what the wires are for in the P&P wire loom, so you can connect everything fairly easy, get your indicators correct. Some stuff I did away with bc I didn’t want a bunch of led indicators all over the place. What exactly is the MIL light? Is that check engine or what’s that on our cars.
 

Reddevil91

10 Year Member
Mar 3, 2010
1,318
517
153
The best spot I've found to run wire into the engine bay is through a grommet behind the left fender. It's very hard to get to. I always remove the whole fender... but you may be able to reach it by removing the fender liner and wheel. If you look in the hinge area you might see it.

I ran a couple extra wires through mine so I wouldn't have to take the fender off to run more. Just rolled them up and hid them behind the drivers strut tower / booster area.
Awe man that sounds intense! Guess I’ll take a look at it.
 

90sickfox

I didn't really have an issue with the stink...
SN Certified Technician
Mar 2, 2015
5,221
4,296
203
42
MIL = Malfunction Indicator Light = Check Engine Light.

We do have a check engine light that will come on to indicate various sensor failures or issues. Not as complex as newer cars but the computer holds codes that can help with diag.
 

TOOLOW91

If you're the village idiot what's that make me?
15 Year Member
Nov 29, 1999
7,296
7,099
234
S.I.NY
Honestly it was actually pretty easy once I got over the wiring fear last night and just went for it. The majority of it was all just plug and play connect the dots except those oil and water which I just ended up using the included male plug then heat shrunk them and plugged them into the ground, 12v, and illumination feeds already in the wire loom, same for the led indicators and plugged them in to their correct wires. It actually came with a detailed explanation so you know what the wires are for in the P&P wire loom, so you can connect everything fairly easy, get your indicators correct. Some stuff I did away with bc I didn’t want a bunch of led indicators all over the place. What exactly is the MIL light? Is that check engine or what’s that on our cars.
This makes me happy to hear . It’s hard to explain on the internet sometimes and get the point across not sounding like an ass . I’m glad you tackled it on your own . Looks sick . Hope I was able to help some
 
  • Like
Reactions: Reddevil91

Reddevil91

10 Year Member
Mar 3, 2010
1,318
517
153
This makes me happy to hear . It’s hard to explain on the internet sometimes and get the point across not sounding like an ass . I’m glad you tackled it on your own . Looks sick . Hope I was able to help some
Appreciate it man, ha yeah I get it but I don’t get offended easily. I’m just glad I could get done. Here is a question for you or anyone else. So got all the senders plugged in decided to run everything out through the old grommet area where the original speedo cable ran through and looks really clean but i need to buy some wire loom. Anyways plugged the cluster in, cranked it and car is running like crap. Hit the battery with a multimeter I bought and reading of 11.7 only bc I noticed the volt meter not showing good charge. Hit the alternator and about the same 11.5, plugged the old cluster back in just to check bang battery 14.6 alternator 14.8, then I read through the instructions and saw this. I now a 12v source from my fans but not sure if I need to run a jumper permanently or is it just a contact the 12v source and touch it to the the green/red stripe wire and that’s it?
ADC18961-BC4A-41EB-8EDC-EB894E535C6D.jpeg
 

Reddevil91

10 Year Member
Mar 3, 2010
1,318
517
153
Permanent.

Stock cluster runs the warnin indicator with a resistor inline to the alt through the LG/R wire

IMG_2349.JPG
Ok just wasn’t sure which I needed to do. Here’s another question but I’m pretty sure I have to replace the gear off the old sensor and put it on the new one right?
CE040B58-B2B2-43D2-9F86-38C30AC9B8B3.jpeg
 

stanglx2002

CT Material here
Mod Dude
Jul 7, 2005
1,368
906
154
Yeah the alternator sensing/excite wire needs to be jumped to ignition which is the green/red wire. Without this hooked up the alternator doesn't know the car is on to charge the battery.
 
  • Like
Reactions: Reddevil91

Reddevil91

10 Year Member
Mar 3, 2010
1,318
517
153
All right guys so after many trial and errors on the fitting, I got it all together. Had to trim and shave the bezel as well the cluster slightly to make everything fit together nicely. As for the wiring I ran the wires for the senders and the speedometer out through the grommet where the old speedo cable came out of the fire wall. Got those all cleaned up, taped up, and covered with wire loom. Ran the senders underneath the intake and the speedo wires through the old route of the original cable. Now I just need to finalize the jumper wire for the alternator. I was able to re-excite the alternator and the guys from classic dash said that’s all I would need unless I unplug the battery but it appears that isn’t so, and needs something permanent as you guys stated. So what would be the best spot for a 12v source to keep all this wiring clean in your all’s opinion? Besides that I just need to calibrate the speedo and do the button routine ‘and drive the 2 miles and get that all finished. All in all I’m glad I took the challenge and didn’t back out, a little more work that I thought. Not as straight forward, but a little modification and it’s done. Still not sure if I’ll keep the monster tach but for now it’s gonna stay.
5AA3A8A6-AF5A-4B21-A4B3-C4A72E238012.jpeg
2846DFCA-7618-4B97-9CD2-844D883139C6.jpeg
FA27F5EA-BF5C-4EF1-86A2-3E0051BBBE97.jpeg
 

CarMichael Angelo

clearly, I’ve got something going on in that hole
SN Certified Technician
Nov 29, 1999
12,491
13,617
234
62
Birmingham, al
m.imdb.com
What is with the redundant tach for the Visually challenged that's reading twice as high as the in dash unit?
You went through all of that trouble to wire and mount those new great looking gauges, and are gonna leave that honkin Planet sized thing still in there?
I can't believe that as big as that thing is, you haven't ran over a dog or an old person yet.;)
If this isn't a drag car, I can't see the reason for it. And if this is a drag car, I can't see the reason for the new speedo and a redundant "smaller" tach.
But that's just me, and like they say,..it's your car.
 
  • Like
Reactions: Reddevil91
Thread starter Similar threads Forum Replies Date
LarsD Lx Left Me Stranded Again Fox 5.0 Mustang Tech 44
O Engine 89 Lx Died And Left Me Stranded Today Fox 5.0 Mustang Tech 8
U2SLO450 my car left me stranded Fox 5.0 Mustang Tech 5
Adam95GT Car Left Me Stranded... UGH! HELP!!! 1994 - 1995 Specific Tech 98
PoopDawg Car left me stranded for the first time ever today... 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 5
F 89 5.0 firing on left bank only. Need ideas Fox 5.0 Mustang Tech 11
C my mechanic Swapped a 99 5.0 explorer 302 into my 94 5.0 left a much of stuff disconnected and abandoned it HELP!!! 1994 - 1995 Specific Tech 15
G Odd shaking on left upper side 1996 - 2004 SN95 Mustang -General/Talk- 4
M My Dad left me a yellow 67 rust bucket :) The Welcome Wagon 1
2 Brakes Right front and left rear brakes locked up. Classic Mustang Specific Tech 6
M Why is my left turn-signal light always lit?!! Fox 5.0 Mustang Tech 8
M Does anyone know what the hole to the left of the oil pressure sender is for?? 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 6
Dustin2v Electrical 2001 GT - Left Sequential Taillight not working SN95 4.6L Mustang Tech 1
S Left blinker stays on with running lights. SN95 4.6L Mustang Tech 11
B 2004 Squeaking and Squealing when I turn wheel left or right The Welcome Wagon 1
B Sticker inside left door jamb SN95 4.6L Mustang Tech 1
R Noise coming from rear left wheel. Getting mixed information from facebook 1996 - 2004 SN95 Mustang -General/Talk- 1
67coupe Progress Thread 67coupe’s 89 LX - One paint session left!!! 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 301
C 1966 left front brake locks up when I radio the brakes Classic Mustang Specific Tech 3
The Shemdogg No left turn power steering 1965 - 1973 Classic Mustangs -General/Talk- 4
B sticking left front brake 1996 - 2004 SN95 Mustang -General/Talk- 9
true01blueGT 2003 mustang gt only left driver tweeter 1996 - 2004 SN95 Mustang -General/Talk- 1
F Humming In The Front Left Of Car 2005 - 2014 Specific V6 Tech 0
G Expired 1970 Mustang Front Left Clip $250 Interior Exterior Parts 0
J Wheel/tire Shakes Bad When Turning Left At Hwy Speed Please Help! 2005 - 2014 S-197 Mustang -General/Talk- 5
Slo5Oh89 Front Left Sagging Fox 5.0 Mustang Tech 6
TheFleshRocket Help! Attempting To Troubleshoot Mach 460 Front Left Tweeter Not Working. Mustang Sound & Shine All 1
9 Aunt Passed And Left Me Her Mustang... What To Do 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 47
teebluestang Fuel Gauge, Speed O, And Left Turn Signal Fox 5.0 Mustang Tech 1
dr. Dan W. Greetings From Way Out In Left Field! The Welcome Wagon 4
MCF84 Expired 2015/2016 Mustang Left Side Hood Vent Interior Exterior Parts 1
Jordan Warta 1995 5.0 Making Creaking Noise With Hard Left Turns? 1994 - 1995 Specific Tech 0
Joshuaachury Brakes Pulling Left When Braking And Random Scrapping Noise When Turning! SN95 V6 Mustang Tech 1
stykthyn Left Bank Exhaust Cold Fox 5.0 Mustang Tech 5
J Dont Know If I Have Enough Hair Left To Pull Out. Need Help With My 95 5.0 5 Speed Gt 1994 - 1995 Specific Tech 5
J Newbie Here. Dont Know If I Have Enough Hair Left To Pull Out. Need Help With My 95 Gt The Welcome Wagon 0
mpcv2000 Electrical Doing A "wire Tuck" On A 93 Lx. Left Frame Rail Side Harness Blk/wht 2 Into 1 Goes Where ? Fox 5.0 Mustang Tech 5
skiwesser11 Dumb Q: Would I Know If Pilot Bearing Was Left Out? Fox 5.0 Mustang Tech 8
C Expired 94-98 Left Rear Brake Caliper - A1 Cardone - Never Installed Wheels Tires Brakes 0
HexMora Rear Right Tire Sticks Out More Than Rear Left Tire. Fox 5.0 Mustang Tech 5
7 88 Gt No Brake Lights/ No Left Rear Turn Signal 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 3
M How Do I Be Left Alone In My 73 Mustang? 1965 - 1973 Classic Mustangs -General/Talk- 19
65Rob Left And Right Control Arms? Classic Mustang Specific Tech 2
M Mach 460 Left Side Not Working 1996 - 2004 SN95 Mustang -General/Talk- 5
Toolmaan 88 Mustang Rust On Frame Rail Below Left Shock Tower Fox 5.0 Mustang Tech 2
Busamike 1965 Fastback 347 Stroker, Whit Smoke Out Of Left Exhaust? Classic Mustang Specific Tech 3
B Help Build A 302 For A Sand Rail Using Left Over Parts... 1965 - 1973 Classic Mustangs -General/Talk- 6
GoldenEagle91 Suspension Clunk When Turning Left Fox 5.0 Mustang Tech 8
MRaburn 2015 Ford Mustang Convertible Enters Stage Left StangNet Site News 0
90lxwhite Any E7 Guys Left Out There? 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 37
Similar threads